NEWS
Released Amazing Template for Phoca Cart
Learn More ...
Phoca Extensions
Powerful extensions for Joomla! CMS

Using PHP version 8.1

If your server is upgraded, e.g. PHP to version 8.1, it is also needed to update Joomla and Phoca extensions.

Phoca Gallery example

If your server is updated to PHP 8.1, it is even needed to update Joomla to version 4 and Phoca Gallery to version 4.5. Latest Joomla 3 Phoca Gallery version (4.4.3) which was released before PHP 8.1, is not compatible with this version.

There are possible ways:

  • use obsolete extensions, but then don't update PHP
  • update PHP, but then Joomla and Phoca extensions need to be updated to latest versions too
  • possibly overwrite those parts in the old extensions that are not compatible with the new PHP 8 version.

We probably all understand that this is not ideal, but both Joomla and PHP are evolving rapidly and therefore Phoca extensions have to keep up with them. And support for the latest technology and the latest CMS version comes in the latest Phoca extensions.

Phoca Forum - Latest Topics

100+
GitHub Projects
Arctic Code
Vault Contributor
12 Million+
Downloads
70 000+
Answered Questions
1 900+
Planted Trees