File Upload doesn't seem to be working or else I cant find them?

Phoca Commander - dual panel file manager for Joomla! CMS
ilox
Phoca Newbie
Phoca Newbie
Posts: 3
Joined: 01 Nov 2016, 13:47

File Upload doesn't seem to be working or else I cant find them?

Post by ilox » 01 Nov 2016, 13:56

I just love this great utility and yes, it does bring me back to the days when Commander was the preferred tool to manage our files.

What I cant get to work is the File Upload. I watched the Video and learnt about how to change the Directory that the File will reside.

I Select the File to be Uploaded and then click on the Upload Button. It goes through the process of counting up to 100% for the Upload. I get the message that the Upload has finished. I close the Upload Windows but there is no file seen!

I have looked all over the site but nowhere can I find the Files that have supposedly been uploaded. I am Super User in my own Site and have full access.

Any idea on where these files might be hiding? Or why the program says that the file has successfully uploaded but either it hasn't uploaded or it has hidden them from view?

Cheers, Ian

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42885
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: File Upload doesn't seem to be working or else I cant find them?

Post by Jan » 01 Nov 2016, 14:18

Hi, try to test it with enabled javascript console (e.g. with help of Firebug extension in Firefox and test if you don't get any error there)

See: https://www.phoca.cz/documents/16-joomla ... -conflicts

Try to upload some really simple e.g. txt file, do you get the same problems?

Jan
If you find Phoca extensions useful, please support the project

ilox
Phoca Newbie
Phoca Newbie
Posts: 3
Joined: 01 Nov 2016, 13:47

Re: File Upload doesn't seem to be working or else I cant find them?

Post by ilox » 02 Nov 2016, 03:36

Thanks for the response Jan, After installing and activating Firebug I got several responses, the only one that made sense was this one:
"{"jsonrpc":"2.0","result":"error","code":109,"message":"Error: ","details":"Unable to upload file<br
\/>Check permissions and ownership of files and folders"}"

So I was able to upload a txt file of 56k and I can see it sittting in the Joomla Root folder.

I was unable to upload the Forum Post Assistant file which is Zipped and around 650k.

I have set the File Upload limit to 0.

I cant do any of this through CPanel as a Hacker has compromised my account which is why I am using Commander to bring in files and let me access them and try to clear the stinkers out of my site.

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42885
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: File Upload doesn't seem to be working or else I cant find them?

Post by Jan » 04 Nov 2016, 15:23

Hi, which version of Joomla! and which version of Phoca Commander do you use?

There were some changes regarding uploading files in Joomla!

Jan
If you find Phoca extensions useful, please support the project

ilox
Phoca Newbie
Phoca Newbie
Posts: 3
Joined: 01 Nov 2016, 13:47

Re: File Upload doesn't seem to be working or else I cant find them?

Post by ilox » 06 Nov 2016, 08:08

Hello Jan, thanks for getting back to me.

Joomla! latest version 3.6.4

Phoca Commander is whatever your current version is, it was downloaded just a day or two ago.

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42885
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: File Upload doesn't seem to be working or else I cant find them?

Post by Jan » 07 Nov 2016, 01:54

Hi, thank you for the info, yes, confirmed, it does not work. I have changed it so it fit new Joomla! feature and now it should work in version 3.0.1.

Please update and let me know:
https://www.phoca.cz/news/917-phoca-comm ... 1-released

Thank you, Jan
If you find Phoca extensions useful, please support the project

Post Reply