Error 404 when Upload Package File com_phocagallery_v4.1.1

Phoca Install - install extension in Joomla! CMS
dangminh01
Phoca Newbie
Phoca Newbie
Posts: 3
Joined: 30 May 2014, 17:39

Error 404 when Upload Package File com_phocagallery_v4.1.1

Post by dangminh01 »

Hello
I have updated my website from Joomla 2.5 to 3.3.
I have then disintalled the old phoca gallery and downloaded the new version 4.1.1, tried to Upload Package File com_phocagallery_v4.1.1 and received an error message 404: "Component not found, return to Control Panel".
Returning to Control Panel shows following messages:
" Folder images/phocagallery/ exists!
Folder images/phocagallery/avatars! exists!"
Could you please provide some guidance, how to solve the problem
Thank you.
User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 48041
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Error 404 when Upload Package File com_phocagallery_v4.1

Post by Jan »

Hi, try to remove the component completely, see:
https://www.phoca.cz/documents/16-joomla ... m-manually

And then try to reinstall it again.

Jan
If you find Phoca extensions useful, please support the project
dangminh01
Phoca Newbie
Phoca Newbie
Posts: 3
Joined: 30 May 2014, 17:39

Re: Error 404 when Upload Package File com_phocagallery_v4.1

Post by dangminh01 »

Hello Jan
Many thanks for your quick reply.
Unfortunately I have no clue about SQL and PHP.
Is there some way around to help me?
Minh
User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 48041
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Error 404 when Upload Package File com_phocagallery_v4.1

Post by Jan »

Hi, sql you can manage in phpmyadmin, but for this someone who has some experiences with sql should be hired :idea:

Jan
If you find Phoca extensions useful, please support the project
Dimi2014
Phoca Member
Phoca Member
Posts: 20
Joined: 03 Oct 2014, 14:09

Re: Error 404 when Upload Package File com_phocagallery_v4.1

Post by Dimi2014 »

Here's what I did and it worked. I went from 2.5.27 to 3.3.6, and Phoca 3.28 to 4.1.1

Disabled all phoca extensions, etc.
Upgraded to 3.3.6 Joomla
Installed Phoca Gallery 4.1.1 w/out enabling the old Phoca components and got a blank page.
Enabled old Phoca extensions and reinstalled 4.1.1 Phoca. It worked for everything except for styles meaning the template that displays the gallery on the frontend couldn't be accessed because there wasn't an entry in the Db but everything else worked.

Well, I had to recreate the single table, xxxxx_phocagallery_styles that was missing, I got a frontend error message listing the missing table. You have to know what you're doing to do this..it's only 1 step for everything to work. Good luck.
User avatar
Benno
Phoca Hero
Phoca Hero
Posts: 9199
Joined: 04 Dec 2008, 11:58
Location: Germany
Contact:

Re: Error 404 when Upload Package File com_phocagallery_v4.1

Post by Benno »

@ Dimi2014
Well Done!! :twisted:

Kind regards,
Benno
Post Reply