automatic shipping issue

Phoca Cart - complex e-commerce extension
jpeters
Phoca Professional
Phoca Professional
Posts: 189
Joined: 31 Dec 2020, 09:46

automatic shipping issue

Post by jpeters » 11 Feb 2021, 07:20

Hello
i just found out that automatic shipping does not work as soon as shipping costs are involved.
tested on 2 sites with both the same results.

automatic shipping method is on

if only one shipping method is available (based on order) with no shipping fees then the shipping method is automaticly selected and you go to the next step.
as soon as the shipping method will cost money it is not automaticly selected and the customer needs to select and confirm.

i use v3.5.6 b4

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 43996
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: automatic shipping issue

Post by Jan » 11 Feb 2021, 18:29

Hi, there is no connection to costs in this feature. So the only idea I have is when there are costs then more shipping methods meet the rules and there is no more one which can be automatically set but two.

Example: there is only one method which meet the rules (even it has costs, it is selected)
Image

Example: there are more methods which meet the rules (even the costs are zero, noone is selected as there are two which meet the rules)

Image

Jan
If you find Phoca extensions useful, please support the project

jpeters
Phoca Professional
Phoca Professional
Posts: 189
Joined: 31 Dec 2020, 09:46

Re: automatic shipping issue

Post by jpeters » 11 Feb 2021, 20:09

Hello Jan,
i should agree with your explanation but i have tested it on 2 installations.
1 completely new with nothing else installed.

as long as the shipping is free it's auto selected. as soon i put in costs it will not be auto selected.
it does work for payment rule..

this is wat i have done (both websites)
remove current shippment.. reset the auto setting (set to no, save, set to yes, save), create 2 shipment.
weight rule based. add cost to shipment, add weight to product and see.

i will do some more testing.. perhaps something else (rule perhaps) is causing this issue.

in your example.. do you have several shipments? if so, what rules are active?

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 43996
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: automatic shipping issue

Post by Jan » 11 Feb 2021, 21:32

Hi, yes, as displayed on the screenshots:

- first only one shipment (second disabled) ... then automatic selection work
- then two shipments (both active, both meet the rules) ... if both meet the rules, there is no automatic selection

No rules set, just both meet the rules to be displayed.

Jan
If you find Phoca extensions useful, please support the project

jpeters
Phoca Professional
Phoca Professional
Posts: 189
Joined: 31 Dec 2020, 09:46

Re: automatic shipping issue

Post by jpeters » 12 Feb 2021, 00:40

Hello Jan,
did some further testing on 2 sites. product has weight defined
#1 1 shipment, no costs, no rules = automatic shipment works
#2 1 shipment, with costs, no rules = automatic shipment works
#3 2 shipment, no cost, no rules = result automatic shipment not applied. both shipment options available
#4 2 shipment, with costs. no rules = automatic shipment not applied. both shipment options available
#5 1 shipment, with cost, country rule active = automatic shipment works
#6 2 shipment, with costs, country rule active = automatic shipment not applied. both shipment option available
#7 1 shipment, with costs, country rule active, weight rule active = automatics shipment not applied.
#8 2 shipment, with costs, country rule active, weight rule active (first 0-100gram, second 101-200 gram)= automatics shipment not applied. both shipment options available
#9 2 shipment, with costs, country rule active, weight rule active (first 0-100gram, second 101-200 gram) = automatics shipment not applied. one shipment option available (product weight 120gram)
#10 2 shipment, with costs, weight rule active (first 0-100gram, second 101-200 gram)= automatics shipment not applied. both shipment options available
#11 2 shipment, with costs, weight rule active (first 0-100gram, second 101-200 gram) = automatics shipment not applied. one shipment option available (product weight 120gram)

it looks like the issue is in the weight rule section.
without the weight rule active it works.
other rules not tested.

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 43996
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: automatic shipping issue

Post by Jan » 15 Feb 2021, 00:50

Hi, thank you for the info, I will take a look at it.

Jan
If you find Phoca extensions useful, please support the project

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 43996
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: automatic shipping issue

Post by Jan » 12 May 2021, 21:31

Hi, testing now all possible combination, no problem with weight rule, automatic shipping method is selected always when the weight meets the rules.

When rule is 0 - 100 and product is 60, automatic shipping method is selected, when the prouduct count is set to 2 (means 2x60 = 120) then there is no shipping method available :idea:

Jan
If you find Phoca extensions useful, please support the project

Post Reply