Unable to publish a message

Before you ask see the Phoca Guestbook User Manual
User avatar
Chti56
Phoca Newbie
Phoca Newbie
Posts: 4
Joined: 06 Nov 2013, 18:45

Unable to publish a message

Post by Chti56 » 13 Dec 2017, 00:47

Hi,
I use Phoca Guestbook v3.0.3 with Joomla v3.8.2
I have the following problem since today...
I can't publish a message !! The message has been written correctly by a customer but when i try to publish (validate) it ... nothing happens.. The message remains unpublished (it is waiting).

What could be the problem ? Compatibility problem with Joomla 3.8.2 ?

Many thanks for help.

Rgds


christine
Phoca Hero
Phoca Hero
Posts: 1306
Joined: 28 Nov 2010, 17:20

Re: Unable to publish a message

Post by christine » 14 Dec 2017, 00:32

Hi,
Chti56 wrote:
13 Dec 2017, 00:47
I use Phoca Guestbook v3.0.3 with Joomla v3.8.2
Current version of Joomla is: J 3.8.3
Current version of Phoca Guestbook is: 3.0.6 https://www.phoca.cz/download/category/ ... -component
I have the following problem since today...
Please update accordingly and advise, if problem still exist.
Kind regards, Christine

rtrzicky
Phoca Member
Phoca Member
Posts: 11
Joined: 02 Jan 2018, 14:43

Re: Unable to publish a message

Post by rtrzicky » 02 Jan 2018, 14:59

Hi Christine,

I have the same problem, message is written and waiting for approval. If I try to publish it I get "1 item successfully published" message in green area in control panel. But it's not true because nothing happened. Joomla 3.8.3, Phoca Guestbook 3.0.6.

It seems to me that function "publish" from "components/com_phocaguestbook/models/guestbook.php" is never called (if it is the right function to be called). I tried to unconditionally return false from this function or set error and the result was the same as I did not change anything.

Best regards
Radek

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 39882
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Unable to publish a message

Post by Jan » 03 Jan 2018, 01:43

Hi, testing now, without any problems :idea:

Image

Is the icon "published" in your administration? When you see php errorLog on your server, do you get any error message there :idea:

https://www.phoca.cz/documents/16-jooml ... rs-on-site

Jan
If you find Phoca extensions useful, please support the project

rtrzicky
Phoca Member
Phoca Member
Posts: 11
Joined: 02 Jan 2018, 14:43

Re: Unable to publish a message

Post by rtrzicky » 03 Jan 2018, 13:55

Hi,

I have red icon in administration and after pushing button and getting OK message (as I wrote before) the same icon stays there.

I have no logs available, I have to ask my provider to enable it if I need it. I will do it. Yesterday I tried to enable debug messages in Joomla administration but I saw no error message during publishing.

I cannot work on it today, I will do more tests tomorrow...

Radek

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 39882
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Unable to publish a message

Post by Jan » 03 Jan 2018, 16:23

Ok, do you even use some cache solution?
If you find Phoca extensions useful, please support the project

rtrzicky
Phoca Member
Phoca Member
Posts: 11
Joined: 02 Jan 2018, 14:43

Re: Unable to publish a message

Post by rtrzicky » 06 Jan 2018, 11:54

Hi, I don't use caches other then Joomla uses internally and I have Joomla system cache set off in administration.
I've activated errorlogs and tried to publish one post but I've got no related error message (I've had Joomla error reporting set to Maximum).
Then I tried to set Debug system on and see sql queries in Debug console. There was no "phocaguestbook_items" table update.
I'm running on PHP 7.1, maybe I can try to switch php version back to 7.0?

rtrzicky
Phoca Member
Phoca Member
Posts: 11
Joined: 02 Jan 2018, 14:43

Re: Unable to publish a message

Post by rtrzicky » 06 Jan 2018, 16:29

I tried with PHP versions 7.0.19, 5.6.30, 5.5.38 and 5.4.45. All of them behave the same way.

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 39882
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Unable to publish a message

Post by Jan » 06 Jan 2018, 21:03

Hi, don't you get any phocaguestbook table when loading the items of guestbook in debug info? (You will not get any when editing gestbooks, these are in fact Joomla! categories, but when publishing/unpublishing items of guestbook, you should see the table of guestbook)

:idea:

Jan
If you find Phoca extensions useful, please support the project

rtrzicky
Phoca Member
Phoca Member
Posts: 11
Joined: 02 Jan 2018, 14:43

Re: Unable to publish a message

Post by rtrzicky » 06 Jan 2018, 21:14

One thing I didn't wrote (because I had all messages unpublished on prod server) - I can successfully unpublish message with all PHP versions.

Post Reply