error after upgrading from 4.3.6 to 4.3.9

Before you ask see the Phoca Gallery User Manual
pmonstad
Phoca Newbie
Phoca Newbie
Posts: 9
Joined: 06 Nov 2015, 21:58

error after upgrading from 4.3.6 to 4.3.9

Post by pmonstad » 11 Jan 2018, 22:32

I get this error when I try to upload an image from backend: Unknown column 'pcproductid' in 'field list'

PHP kompilert på Linux cpanel32.proisp.no 2.6.32-673.26.1.lve1.4.22.el6.x86_64 #1 SMP Fri Feb 24 08:35:09 EST 2017 x86_64
Databaseversjon 5.5.56-cll-lve
Databasekollasjon latin1_swedish_ci
Database Connection Collation utf8mb4_general_ci
PHP-versjon 7.1.13
Nettstedstjener Apache
Nettstedstjener til PHP-grensesnitt litespeed
Joomla!-versjon Joomla! 3.8.3 Stable [ Amani ] 12-December-2017 15:00 GMT
Joomla-plattformversjon Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT

Tags:


darkholokaust
Phoca Newbie
Phoca Newbie
Posts: 9
Joined: 16 Aug 2017, 18:17

Re: error after upgrading from 4.3.6 to 4.3.9

Post by darkholokaust » 12 Jan 2018, 13:59

hello!
comfirmed bug... when upgrading from 4.3.6 to newer, the db is not correcly modified.
I tryed on a test site to uninstall and reinstall phoca gallery, but i missed all images and categories, so be carefull! but the problem gone.
You can solve it by adding the missing fields manually. Connect to phpmyadmin or else and execute this query, where XXXXX is the prefix of your tables

Code: Select all

ALTER TABLE `XXXXX_phocagallery` ADD `pcproductid` INT(11) NOT NULL DEFAULT '0' AFTER `vmproductid`;
PS.
while checking the table, i figure out that also 'format' field was missing. If is the same to you

Code: Select all

ALTER TABLE `XXXXX_phocagallery` ADD `format` TINYINT(1) NOT NULL DEFAULT '0' AFTER `filename`;

christine
Phoca Hero
Phoca Hero
Posts: 1259
Joined: 28 Nov 2010, 17:20

Re: error after upgrading from 4.3.6 to 4.3.9

Post by christine » 13 Jan 2018, 12:00

Hi darkholokaust,
thank you for your information. Indeed, it's not useful to uninstall PG/reinstall PG :-)

Hi pmonstad,

in generell, before updating PG version, you should check following:
PG > Control Panel > Info > Check for Update. If you see, similiar to this:
Current Version: 4.3.6
Your version: 4.3.9
then you might hv upgraded to new PG version, but the SQL Update Server didn't work. Therefore, check always given: Current Version in 1st line- before updating. Does it work now for you?

Kind regards
Christine

pmonstad
Phoca Newbie
Phoca Newbie
Posts: 9
Joined: 06 Nov 2015, 21:58

Re: error after upgrading from 4.3.6 to 4.3.9

Post by pmonstad » 15 Jan 2018, 18:49

ALTER TABLE `XXXXX_phocagallery` ADD `pcproductid` INT(11) NOT NULL DEFAULT '0' AFTER `vmproductid`;

This fixed to problem for me. Thanks!

christine
Phoca Hero
Phoca Hero
Posts: 1259
Joined: 28 Nov 2010, 17:20

Re: error after upgrading from 4.3.6 to 4.3.9

Post by christine » 15 Jan 2018, 18:59

Hi pmonstad,

thank you very much for your information! 8)

I think above problem occurs of versions updates (resp. SQL Server) in a "short time" between 3.4.7, 3.4.8, 3.4.9. maybe too great step in once from 4.3.6 to 4.3.9.

Kind regards
Christine

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 39524
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: error after upgrading from 4.3.6 to 4.3.9

Post by Jan » 15 Jan 2018, 21:57

Hi, confirmed, version 4.3.9 is missing the instruction for 4.3.7 update ( administrator/components/com_phocagallery/update/sql/mysql\4.3.7.sql

Should be fixed in version 4.3.10
https://www.phoca.cz/download/category/ ... -component

Thank you.
Jan
If you find Phoca extensions useful, please support the project

malban
Phoca Newbie
Phoca Newbie
Posts: 1
Joined: 27 Jan 2018, 19:47

Re: error after upgrading from 4.3.6 to 4.3.9

Post by malban » 27 Jan 2018, 19:51

Thanks pmonstad, it works for me too:

ALTER TABLE `xxxxx_phocagallery` ADD `pcproductid` INT(11) NOT NULL DEFAULT '0' AFTER `vmproductid`;

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 39524
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: error after upgrading from 4.3.6 to 4.3.9

Post by Jan » 28 Jan 2018, 15:21

Ok
If you find Phoca extensions useful, please support the project

Tersia
Phoca Newbie
Phoca Newbie
Posts: 7
Joined: 02 May 2014, 15:50

Re: error after upgrading from 4.3.6 to 4.3.9

Post by Tersia » 15 Mar 2018, 10:01

Problem still persists in 4.3.10
1054 Unknown column 'pcproductid' in 'field list'

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 39524
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: error after upgrading from 4.3.6 to 4.3.9

Post by Jan » 18 Mar 2018, 14:32

Hi, this seems like your Joomla! didn't upgrade the Phoca Gallery well - pcproductid column is missing in your database and needs to be added manually:

administrator\components\com_phocagallery\update\sql\mysql\4.3.7.sql

This query should be run in your database (e.g. per phpMyAdmin, #__ should be changed to your database prefix):

Code: Select all

ALTER TABLE `#__phocagallery` ADD COLUMN `pcproductid` int(11) NOT NULL DEFAULT '0';
Jan
If you find Phoca extensions useful, please support the project

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest