phoca 4.1.2 and joomla 3.4 upgrade error.

Phoca Gallery - image gallery extension
christine
Phoca Hero
Phoca Hero
Posts: 1707
Joined: 28 Nov 2010, 17:20

Re: phoca 4.1.2 and joomla 3.4 upgrade error.

Post by christine » 11 Jun 2019, 12:48

Hi Joan,

1) Try again to upgrade your Phoca Gallery. Current version: 4.3.18 https://www.phoca.cz/download/category/ ... -component > Download and update via Joomla! Update Package procedure.

2) Press: database Fix button.

3) If message still exist: Run via phpMyAdmin SQL:

Code: Select all

ALTER TABLE `#__phocagallery_categories` ADD COLUMN `image_id` int(11) NOT NULL default 0;
#_with your prefix!

4) Video: https://www.phoca.cz/documents/2-phoca- ... ube-videos

Kind regards
Christine

User avatar
Benno
Phoca Hero
Phoca Hero
Posts: 7134
Joined: 04 Dec 2008, 11:58
Location: Germany
Contact:

Re: phoca 4.1.2 and joomla 3.4 upgrade error.

Post by Benno » 11 Jun 2019, 13:00

@jagy
1. Missing column:
see: https://www.phoca.cz/documents/16-jooml ... ase-column
2.) YouTube:
backend --> Components --> Phoca Gallery --> Control Panel --> Options --> General Settings --> YouTube API Key=(Copy & paste your API Key)

Kind regards,
Benno

Edit: Sorry too late. Christine was faster ;-)

jagy
Phoca Member
Phoca Member
Posts: 13
Joined: 03 Apr 2013, 17:32

Re: phoca 4.1.2 and joomla 3.4 upgrade error.

Post by jagy » 11 Jun 2019, 14:35

Thank you both,
The query functionned well, I added the Youtube API - but- I get an error msg:

1054 Unknown column 'pcproductid' in 'field list'

I'm unable to add a video. How can I solve this?
Thanks

User avatar
Benno
Phoca Hero
Phoca Hero
Posts: 7134
Joined: 04 Dec 2008, 11:58
Location: Germany
Contact:

Re: phoca 4.1.2 and joomla 3.4 upgrade error.

Post by Benno » 11 Jun 2019, 17:07

Hi,
make a backup of your database before and then run this query:

Code: Select all

ALTER TABLE `#__phocagallery` ADD COLUMN `pcproductid` int(11) NOT NULL DEFAULT '0';
Kind regards,
Benno

jagy
Phoca Member
Phoca Member
Posts: 13
Joined: 03 Apr 2013, 17:32

Re: phoca 4.1.2 and joomla 3.4 upgrade error.

Post by jagy » 12 Jun 2019, 14:32

Thank you very much Benno, the query worked and I was able to publish the YouTube video normally.

There are still two oddities:
1.in the Phoca Gallery control panel the "version" is empty when it should read 4.3.18 .
2.many labels are missing, you see only some resembling this: COM_PHOCAGALLERY_IMGUR_SETTINGS

I'd like to fix that also to avoid future upgrade problems.

Kind regards
Joan

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 41599
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: phoca 4.1.2 and joomla 3.4 upgrade error.

Post by Jan » 15 Jun 2019, 12:11

Hi, will be great to list all missing labels so I can check them.

Jan
If you find Phoca extensions useful, please support the project

jagy
Phoca Member
Phoca Member
Posts: 13
Joined: 03 Apr 2013, 17:32

Re: phoca 4.1.2 and joomla 3.4 upgrade error.

Post by jagy » 17 Jun 2019, 11:43

Hi Jan,
Here's the list of missing labels, they're incomplete because that's all that can be seen and copied but I'm sure you can identify them. Could you tell me what file they're in? Also, the Version doesn't show either. Thanks for your help. Joan

In Options/ Detail view

COM_PHOCAGALLERY_FIELD_SHADOW_BOX_S
COM_PHOCAGALLERY_CONFIG_PHOTOSWIPE_SETTINGS_LABEL
COM_PHOCAGALLERY_FIELD_PHOTOSWIPE_SLIDESHOW_LABEL
COM_PHOCAGALLERY_FIELD_DISPLAY_CAPTION_LABEL
COM_PHOCAGALLERY_FIELD_PHOTOSWIPE_DISABLE_SLIDE_EFFECT_LABEL

COM_PHOCAGALLERY_FIELD_YOUTUBE_API_KEY_LABEL
COM_PHOCAGALLERY_FIELD_YOUTUBE_API_S
COM_PHOCAGALLERY_FIELD_RESPONSIVE_DESIGN_LABEL
COM_PHOCAGALLERY_FIELD_BOOTSTRAP3_ICONS_LABEL
COM_PHOCAGALLERY_FIELD_EQUAL_HEIGHTS_LABEL
COM_PHOCAGALLERY_FIELD_DISABLE_MOOTO

COM_PHOCAGALLERY_FIELD_MAP_TYPE_LABEL
COM_PHOCAGALLERY_FIELD_MAPS_API_KEY_LABEL
COM_PHOCAGALLERY_FIELD_MAPS_API_SSL_ENABLED_LABEL
COM_PHOCAGALLERY_FIELD_OSM_MAP_TYPE_OSM_LABEL
COM_PHOCAGALLERY_FIELD_MAP_API_KEY_OSM_LABEL
COM_PHOCAGALLERY_FIELD_THUNDERFORES
COM_PHOCAGALLERY_FIELD_DISPLAY_PC_LIN

COM_PHOCAGALLERY_FIELD_DEFAULT_ACCESS_LABEL
COM_PHOCAGALLERY_FIELD_DEFAULT_ACCES

COM_PHOCAGALLERY_FIELD_MARGIN_ADDITIO
COM_PHOCAGALLERY_FIELD_EXIF_ROTATE_LA

CATEGORIES
COM_PHOCAGALLERY_IMGUR_SETTINGS
COM_PHOCAGALLERY_FIELD
COM_PHOCAGALLERY_FIELD_IMGUR_CLIENT_ID_LABEL
COM_PHOCAGALLERY_FIELD_IMGUR_ALBUM_ID_LABEL

IMAGES
COM_PHOCAGALLERY_FIEL

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 41599
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: phoca 4.1.2 and joomla 3.4 upgrade error.

Post by Jan » 19 Jun 2019, 21:27

Hi, in which language are they missing? I tested the English, and they are included. :idea:

Jan
If you find Phoca extensions useful, please support the project

jagy
Phoca Member
Phoca Member
Posts: 13
Joined: 03 Apr 2013, 17:32

Re: phoca 4.1.2 and joomla 3.4 upgrade error.

Post by jagy » 20 Jun 2019, 09:56

Hi Jan,
I'm using English. It seems to me that there was a problem with the upgrading process, it doesn't show a version number.
Thanks
Joan

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 41599
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: phoca 4.1.2 and joomla 3.4 upgrade error.

Post by Jan » 20 Jun 2019, 11:20

Hmm, and are you able to install latest version again? What message do you get when installing it?

Jan
If you find Phoca extensions useful, please support the project

Post Reply