phoca 4.1.2 and joomla 3.4 upgrade error.

Phoca Gallery - image gallery extension
christine
Phoca Hero
Phoca Hero
Posts: 1613
Joined: 28 Nov 2010, 17:20

Re: phoca 4.1.2 and joomla 3.4 upgrade error.

Post by christine » 11 Jun 2019, 12:48

Hi Joan,

1) Try again to upgrade your Phoca Gallery. Current version: 4.3.18 https://www.phoca.cz/download/category/ ... -component > Download and update via Joomla! Update Package procedure.

2) Press: database Fix button.

3) If message still exist: Run via phpMyAdmin SQL:

Code: Select all

ALTER TABLE `#__phocagallery_categories` ADD COLUMN `image_id` int(11) NOT NULL default 0;
#_with your prefix!

4) Video: https://www.phoca.cz/documents/2-phoca- ... ube-videos

Kind regards
Christine

User avatar
Benno
Phoca Hero
Phoca Hero
Posts: 7072
Joined: 04 Dec 2008, 11:58
Location: Germany
Contact:

Re: phoca 4.1.2 and joomla 3.4 upgrade error.

Post by Benno » 11 Jun 2019, 13:00

@jagy
1. Missing column:
see: https://www.phoca.cz/documents/16-jooml ... ase-column
2.) YouTube:
backend --> Components --> Phoca Gallery --> Control Panel --> Options --> General Settings --> YouTube API Key=(Copy & paste your API Key)

Kind regards,
Benno

Edit: Sorry too late. Christine was faster ;-)

jagy
Phoca Member
Phoca Member
Posts: 10
Joined: 03 Apr 2013, 17:32

Re: phoca 4.1.2 and joomla 3.4 upgrade error.

Post by jagy » 11 Jun 2019, 14:35

Thank you both,
The query functionned well, I added the Youtube API - but- I get an error msg:

1054 Unknown column 'pcproductid' in 'field list'

I'm unable to add a video. How can I solve this?
Thanks

User avatar
Benno
Phoca Hero
Phoca Hero
Posts: 7072
Joined: 04 Dec 2008, 11:58
Location: Germany
Contact:

Re: phoca 4.1.2 and joomla 3.4 upgrade error.

Post by Benno » 11 Jun 2019, 17:07

Hi,
make a backup of your database before and then run this query:

Code: Select all

ALTER TABLE `#__phocagallery` ADD COLUMN `pcproductid` int(11) NOT NULL DEFAULT '0';
Kind regards,
Benno

jagy
Phoca Member
Phoca Member
Posts: 10
Joined: 03 Apr 2013, 17:32

Re: phoca 4.1.2 and joomla 3.4 upgrade error.

Post by jagy » 12 Jun 2019, 14:32

Thank you very much Benno, the query worked and I was able to publish the YouTube video normally.

There are still two oddities:
1.in the Phoca Gallery control panel the "version" is empty when it should read 4.3.18 .
2.many labels are missing, you see only some resembling this: COM_PHOCAGALLERY_IMGUR_SETTINGS

I'd like to fix that also to avoid future upgrade problems.

Kind regards
Joan

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 41217
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: phoca 4.1.2 and joomla 3.4 upgrade error.

Post by Jan » 15 Jun 2019, 12:11

Hi, will be great to list all missing labels so I can check them.

Jan
If you find Phoca extensions useful, please support the project

Post Reply