Error in Phoca Gallery Plugin !

Phoca Gallery plugins - plugins for Phoca Gallery extension
User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 41217
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Error in Phoca Gallery Plugin !

Post by Jan » 05 Nov 2017, 15:43

Hmm, the problem for me is, I am testing with PHP 7.1 and get no such problem :idea:

Image


PHP is 7.1.8
Image

Are the image internal or external (picasa, facebook)?
What is the settings for thumbnails in administration?

Jan
If you find Phoca extensions useful, please support the project

rbuelund
Phoca Enthusiast
Phoca Enthusiast
Posts: 59
Joined: 22 Mar 2015, 00:18
Contact:

Re: Error in Phoca Gallery Plugin !

Post by rbuelund » 05 Nov 2017, 17:52

Internal images. Which PHP modules need to be installed? - maybe there are som e other default settings in PHP 7.1 ?

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 41217
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Error in Phoca Gallery Plugin !

Post by Jan » 05 Nov 2017, 21:03

I got an advice from Christine, that there was a similar case and maybe this could be caused by "getimagesize" function on the server (but hard to say, as the similar case was not solved).

Try to see Phoca Gallery Info page in administration and check if the function is enabled?

Jan
If you find Phoca extensions useful, please support the project

Brujo-mlq
Phoca Newbie
Phoca Newbie
Posts: 2
Joined: 11 Dec 2017, 08:24

Re: Error in Phoca Gallery Plugin !

Post by Brujo-mlq » 11 Dec 2017, 08:39

good morning, I have also the issue with the plugin [] operator not supported for strings when I switch from php 7.0.x -> 7.1.x

[] operator not supported for strings
httpdocs/plugins/content/phocagallery/phocagallery.php:906
Call stack
# Function Location
1 () JROOT/plugins/content/phocagallery/phocagallery.php:906

Line 906 shows:
$data_outcome_array[] = $data_outcome;

Plugin Version: 4.3.4
Gallery: 4.3.6
Joomla; 3.8.2

kind regards
Brujo

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 41217
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Error in Phoca Gallery Plugin !

Post by Jan » 11 Dec 2017, 20:10

Hi, should be OK in version 4.3.5, please update and test:
https://www.phoca.cz/download/category/ ... ery-plugin

and let me know.

Thank you, Jan
If you find Phoca extensions useful, please support the project

Brujo-mlq
Phoca Newbie
Phoca Newbie
Posts: 2
Joined: 11 Dec 2017, 08:24

Re: Error in Phoca Gallery Plugin !

Post by Brujo-mlq » 11 Dec 2017, 20:57

Hey Jan,

thanks a lot, the error message is gone with the plugin version 4.3.5 - tested with php 7.1.12 & 7.2.0

kind regards
Brujo

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 41217
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Error in Phoca Gallery Plugin !

Post by Jan » 11 Dec 2017, 21:36

Ok, great to hear it.

Jan
If you find Phoca extensions useful, please support the project

baschwar
Phoca Newbie
Phoca Newbie
Posts: 5
Joined: 07 Nov 2014, 18:31

Re: Error in Phoca Gallery Plugin !

Post by baschwar » 10 Jan 2019, 00:42

I'm seeing this error now with PHP7.1.
Trying to add a gallery category short code using Gantry5.
This error only appears when adding the string:

Code: Select all

{ phocagallery view=categories|imagecategories=0|imagecategoriessize=0|hidecategories=10,6 }
Error: [] operator not supported for strings: [] operator not supported for strings

All other pages load fine.
Even the gallery pages have this issue.
If I downgrade to php 5.6 everything is OK.

Not sure what else to do, other than find another gallery plugin.

Brad


Here's the Joomla config info:

PHP Built On Linux hoster905.com 4.14.81-grsec #1 SMP Thu Nov 15 04:33:00 EST 2018 x86_64
Database Type mysql
Database Version 5.7.23-percona-sure1-log
Database Collation utf8_general_ci
Database Connection Collation utf8mb4_general_ci
PHP Version 7.2.10
Web Server Apache
WebServer to PHP Interface cgi-fcgi
Joomla! Version Joomla! 3.9.1 Stable [ Amani ] 27-November-2018 15:00 GMT
Joomla! Platform Version Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT
User Agent Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 41217
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Error in Phoca Gallery Plugin !

Post by Jan » 13 Jan 2019, 15:16

Hi, what is the exact error message? Including the file and line? (Enable debug mode to see it or take a look at the errorLog)
If you find Phoca extensions useful, please support the project

Post Reply