Page 1 of 1

Error Unable to detect manifest file.

Posted: 27 Jul 2020, 09:44
by Nobody55
Hello everyone,
I am not yet familiar with the 360 extensions of joomla. The Phoca Panaorama module seemed like a great opportunity. I have a Xampp local and put the latest joomla on it (.20). With both extensions Phoca Panorama, I got
"Error
Unable to detect manifest file."
I was trying a bit and then I got Phoca Panarama visible under components. Some of it worked in the back office but on the frontend I got a 404 error. Then I also installed Phoca Commander with the same error.
Because it could be my Xamp, I also tried to install it on the tynihousetower.com with the same error messages. Has anything changed with the latest Joomla update that is causing these issues?
How can I solve this?
please help me.

Re: Error Unable to detect manifest file.

Posted: 27 Jul 2020, 21:39
by Jan
Hi, can you paste a screenshots of the errors?

Any extension does not install itself, it is installed by Joomla! extension manager, so maybe there is some problem inside Joomla! extension manager :idea:

Jan

Re: Error Unable to detect manifest file.

Posted: 30 Jul 2020, 09:20
by Nobody55
Thanks for your response. Here are the screenshots. I just don't expect them to provide more info.
https://imgur.com/a/B6kevuq
Forums are still new to me. I hope I did everything right.

Re: Error Unable to detect manifest file.

Posted: 30 Jul 2020, 10:55
by christine
Hi,

Try to download from here: https://www.phoca.cz/download/category/ ... -component via: "Upload Package File" instead of via "Install from Web"

Kind regards
Christine

Re: Error Unable to detect manifest file.

Posted: 31 Jul 2020, 09:48
by Nobody55
This installs without errors.
I have also downloaded and installed the module in this way with no problems.
Any idea why it gives error messages the other way?

Now I'm going to see if I get it to work properly.
If I have questions you will see them appear.
Thanks for the support.

Re: Error Unable to detect manifest file.

Posted: 31 Jul 2020, 12:13
by christine
Hi,
Nobody55 wrote:
31 Jul 2020, 09:48
This installs without errors.
I have also downloaded and installed the module in this way with no problems.
OK, I'm always using this way.
Any idea why it gives error messages the other way?
As I'm generally not using the extension: "Install from Web", installed it now just for testing purposes & tried to install the package.
I also got message: Error Invalid URL Unable to find install package. Will inform Jan about.

@Jan: The installer is calling it from here: https://www.phoca.cz/download/category/ ... -component but not directly the file. Therefore no XML Setup File.

Kind regards
Christine

Re: Error Unable to detect manifest file.

Posted: 03 Aug 2020, 15:06
by Jan
Hi, unfortunately current JED is not ready for changing links based on actual version (like the update feature in Joomla!) so for not the package needs to be downloaded and installed through standard process. Hopefully this will be changed in some of the next JED version :idea:

Jan

Re: Error Unable to detect manifest file.

Posted: 06 Aug 2020, 08:25
by Nobody55
Thanks for the update