Is current Phoca Cart compatible with PHP 8.1?

Phoca Cart - complex e-commerce extension
Alexander
Phoca Member
Phoca Member
Posts: 42
Joined: 15 Jan 2020, 17:36

Is current Phoca Cart compatible with PHP 8.1?

Post by Alexander » 23 Jun 2022, 13:24

Hi Jan

... long time. I hope you are doing well!

Sorry to ask this question but in the forum I can not search for "php 8". Maybe it's been answered already.

I'm planning to upgrade my site to Joomla 4 and, while I'm at it, to PHP 8.1.
Are all Phoca modules php 8.1 compatible?

Kind regards

Alexander

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 45190
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Is current Phoca Cart compatible with PHP 8.1?

Post by Jan » 27 Jun 2022, 16:33

Hi, for now I would not recommend to upgrade PHP to PHP8.1 on live site as there were a lot of changes and a lot of warnings are produced. I run 8.1 on my development server so all possible warnings and notices are fixed but it will take some time when it will be released as stable. On my localhost it is OK, in some days some new Beta version even will be OK for 8.1 but it will take some time when stable will be. But what I can say now is, that next stable version will be 8.1 ready.

Jan
If you find Phoca extensions useful, please support the project

Alexander
Phoca Member
Phoca Member
Posts: 42
Joined: 15 Jan 2020, 17:36

Re: Is current Phoca Cart compatible with PHP 8.1?

Post by Alexander » 27 Jun 2022, 16:45

Hi Jan, thank you for the answer. I already went back to PHP 8.0. Other extensions also did not really like PHP 8.1.

As 8.1 is the latest PHP release my provider offers and as I have to migrate my whole site inkluding all my modules to Joomla 4.x and PHP 7.? to PHP 8.? I thought I just fix all problems in one big effort ;)

I can wait, no problem.

Alexander
Phoca Member
Phoca Member
Posts: 42
Joined: 15 Jan 2020, 17:36

Re: Is current Phoca Cart compatible with PHP 8.1?

Post by Alexander » 27 Jun 2022, 16:46

Problem solved

Thank you

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 45190
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Is current Phoca Cart compatible with PHP 8.1?

Post by Jan » 27 Jun 2022, 16:51

Ok
If you find Phoca extensions useful, please support the project

Post Reply