Ask question : photo not displayed when a category link in menu exists

Phoca Cart - complex e-commerce extension
E.P-B
Phoca Member
Phoca Member
Posts: 12
Joined: 13 Apr 2021, 21:42

Ask question : photo not displayed when a category link in menu exists

Post by E.P-B » 16 Apr 2021, 11:08

Hi,
Let me explain my issue : usually, when I click on "Ask a question", the photo of the related product is displayed at the top of the form.
But when SEO URL is set to Yes in joomla global config AND if there is a menu item pointing to a specific category, the photo in ask a question form disappears for all items in that category....
Do you have any idea ?

Ex: item with a category menu item -> photo not displayed (https://demo.joomforest.net/j3/jf_siren ... arcu-porta)
Ex: item without a category menu -> photo displayed (https://demo.joomforest.net/j3/jf_siren ... rown-light)


Thanks in advance,
E.P-B

Tags:

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 43983
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Ask question : photo not displayed when a category link in menu exists

Post by Jan » 16 Apr 2021, 16:30

Hi, hmmm, really hard to say, did you ask the template developer? If this is not related to template?

In standard output (component output), the displaying of image is not related to menu item settings, it is displayed standardly :idea:

components\com_phocacart\views\question\tmpl\default.php

Jan
If you find Phoca extensions useful, please support the project

E.P-B
Phoca Member
Phoca Member
Posts: 12
Joined: 13 Apr 2021, 21:42

Re: Ask question : photo not displayed when a category link in menu exists

Post by E.P-B » 20 Apr 2021, 19:22

Hi again,
I solved this problem by hacking components/com_phocacart/views/question/view.html.php.
I changed line 84:

Code: Select all

// initial code:	if ($id > 0 && $catid > 0) {
if ($id > 0) {
It's ok now.
Thank you for your help.
E.P-B

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 43983
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Ask question : photo not displayed when a category link in menu exists

Post by Jan » 21 Apr 2021, 13:02

Ok, thank you very much for this information.


Jan
If you find Phoca extensions useful, please support the project

E.P-B
Phoca Member
Phoca Member
Posts: 12
Joined: 13 Apr 2021, 21:42

Re: Ask question : photo not displayed when a category link in menu exists

Post by E.P-B » 21 Apr 2021, 16:05

I hope there won't be any side effect... I guess it won't, but... who knows !
Regards,
E.P-B

Post Reply