Product Attribute checkbox not working

Phoca Cart - complex e-commerce extension
derChristoph
Phoca Newbie
Phoca Newbie
Posts: 9
Joined: 21 Dec 2020, 18:05

Product Attribute checkbox not working

Post by derChristoph » 21 Dec 2020, 18:14

I'm using
  • Version 3.5.5Beta
    Joomla!-Version 3.9.23
    OS SunOS l
    PHP 7.4.13
    MySQLi 5.6.42-log
I have a Product with one Simple Checkbox atribute. And the Eventlisener returns always !1: https://i.imgur.com/YFOFSjw.png
See for yourself: https://schuppesser.de/shop
What is a quick workaround?

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 43634
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Product Attribute checkbox not working

Post by Jan » 21 Dec 2020, 22:17

Hi, try to download and update to Beta 2 version (3.5.5 Beta2):
https://github.com/PhocaCz/PhocaCart/re ... 5Beta2.zip

(I have changed the JS code, it should be OK)

BTW, you can disable running minified JS versions in Phoca Cart (e.g. for tests) in Options:

Image

Let me know, if this Beta2 and selecting attribute works for you.

Jan
If you find Phoca extensions useful, please support the project

derChristoph
Phoca Newbie
Phoca Newbie
Posts: 9
Joined: 21 Dec 2020, 18:05

Re: Product Attribute checkbox not working

Post by derChristoph » 22 Dec 2020, 12:48

It worked thank you!

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 43634
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Product Attribute checkbox not working

Post by Jan » 25 Dec 2020, 22:40

Ok, great to hear it.

Jan
If you find Phoca extensions useful, please support the project

Post Reply