Update Error 3.5

Phoca Cart - complex e-commerce extension
fw115
Phoca Member
Phoca Member
Posts: 28
Joined: 27 Mar 2017, 15:25

Update Error 3.5

Post by fw115 » 22 Apr 2020, 09:34

The following error pops up, after trying to update to 3.5:

SQLSTATE[42000]: Syntax error or access violation: 1118 Row size too large. The maximum row size for the used table type, not counting BLOBs, is 8126. This includes storage overhead, check the manual. You have to change some columns to TEXT or BLOBs
Paket Aktualisierung: Bei der Installation der Erweiterung trat ein Fehler auf: com_phocacart_v3.5.0.zip

any ideas ?

thanks

Tags:

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42872
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Update Error 3.5

Post by Jan » 23 Apr 2020, 17:59

Hi, can you paste a screenshots of the error? Where do you get this error? When you update the component? Where did you update it? If in Joomla! extension manager, try to enable debug mode in your global configuration to get more info. It seems like it is some error message coming directly from database when Joomla! tries to write some info about the extension. :idea:

Which webhosting server do you use? When I google such error, it somehow comes e.g. on siteground hostings:

stackoverflow.com/questions/45681365/mysql-error-1118-row-size-too-large-8126-no-access-to-sql-config
joomlapolis.com/forum/153-professional-member-support/237990-database-error-message-1118-row-size-too-large

Maybe support on webhosting can somehow help :idea:

Jan
If you find Phoca extensions useful, please support the project

fw115
Phoca Member
Phoca Member
Posts: 28
Joined: 27 Mar 2017, 15:25

Re: Update Error 3.5

Post by fw115 » 23 Apr 2020, 23:09

Well issue is described here:

https://mariadb.com/kb/en/troubleshooti ... th-innodb/

After altering all tables, the issue is solved.

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42872
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Update Error 3.5

Post by Jan » 24 Apr 2020, 14:34

Hi, great to hear it and thank you for the info.

Jan
If you find Phoca extensions useful, please support the project

Post Reply