Multilanguage Phoca Upgrade System Plugin?

Phoca Cart - complex e-commerce extension
Alexander
Phoca Member
Phoca Member
Posts: 39
Joined: 15 Jan 2020, 17:36

Multilanguage Phoca Upgrade System Plugin?

Post by Alexander » 17 Feb 2020, 11:37

Dear Phoca Gurus

I installed the Phoca Upgrade System Plugin because it seemed to be a good way to force templates for different views and solve bootstrap issues. But it does not work for Multilanguage sites as only one language template can be forded. I have a Template for the German and one for the English pages of my Shop.

As it is a Plugin, I can not use language based (EN, DE) versions of the plugin (or better, I don't know how), one for German and one for English. Is there a way I can solve this problem other than trying to rearrange the 2 Templates and build one Multilanguage Template for both shops which would be a lot of work and might not work for all features.

Thank you and kind regards

Alexander

Tags:

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 43975
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Multilanguage Phoca Upgrade System Plugin?

Post by Jan » 19 Feb 2020, 00:37

Hi, the plugin is a Joomla! system plugin, it just runs independent to languages. What exactly do you want to achieve with this plugin?

Jan
If you find Phoca extensions useful, please support the project

Alexander
Phoca Member
Phoca Member
Posts: 39
Joined: 15 Jan 2020, 17:36

Re: Multilanguage Phoca Upgrade System Plugin?

Post by Alexander » 19 Feb 2020, 12:06

Hi Jan, I would like to use 2 templates for the shop as you described in the phoca cart documentation for "Setting Up Phoca Cart and Gantry5 Template". But I already have a German and an English template for the German and English versions. In the Plugin I can only pick one template.

Kind regards

Alexander

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 43975
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Multilanguage Phoca Upgrade System Plugin?

Post by Jan » 21 Feb 2020, 16:08

Hi, yes, unfortunately the upgrade plugin can assign only one template to component, so if there is some specific need like differentiate between language, this needs to be customized directly in the code :idea:

Jan
If you find Phoca extensions useful, please support the project

Alexander
Phoca Member
Phoca Member
Posts: 39
Joined: 15 Jan 2020, 17:36

Re: Multilanguage Phoca Upgrade System Plugin?

Post by Alexander » 21 Feb 2020, 19:53

Hi Jan, thank you for the information. I will try to make just one template for the DE/EN shop, this will solve the problem.
Thank you for your help!

Alexander

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 43975
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Multilanguage Phoca Upgrade System Plugin?

Post by Jan » 22 Feb 2020, 13:21

Ok
If you find Phoca extensions useful, please support the project

Alexander
Phoca Member
Phoca Member
Posts: 39
Joined: 15 Jan 2020, 17:36

Re: Multilanguage Phoca Upgrade System Plugin?

Post by Alexander » 19 Apr 2021, 18:42

Thank you, this thread can be marked as solved

Alexander

User avatar
Benno
Phoca Hero
Phoca Hero
Posts: 7828
Joined: 04 Dec 2008, 11:58
Location: Germany
Contact:

Re: Multilanguage Phoca Upgrade System Plugin?

Post by Benno » 19 Apr 2021, 23:08

Done!

Kind regards,
Benno

Post Reply