Syntax error in pagination.php on line 41 after Update to 3.03

Phoca Cart - complex e-commerce extension
fw115
Phoca Member
Phoca Member
Posts: 32
Joined: 27 Mar 2017, 15:25

Syntax error in pagination.php on line 41 after Update to 3.03

Post by fw115 » 22 Jan 2018, 02:27

Code: Select all

[Mon Jan 22 01:25:46.948784 2018] [fcgid:warn] [pid 30640] [client 192.168.0.31:52010] mod_fcgid: stderr: PHP Parse error:  syntax error, unexpected ':', expecting ';' or '{' in /var/www/clients/xxxxxx/administrator/components/com_phocacart/libraries/phocacart/pagination/pagination.php on line 41

fw115
Phoca Member
Phoca Member
Posts: 32
Joined: 27 Mar 2017, 15:25

Re: Syntax error in pagination.php on line 41 after Update to 3.03

Post by fw115 » 22 Jan 2018, 13:08

Hello ?

can you confirm this ? are you working on it ? Some infos would be nice , because the shop does not work and i am afraid to go back to 3.02 that would maybe cause more issues .

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 43634
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Syntax error in pagination.php on line 41 after Update to 3.03

Post by Jan » 22 Jan 2018, 15:57

Hi, which PHP version do you run?

Please open the file:
administrator/components/com_phocacart/libraries/phocacart/pagination/pagination.php

and on line 41
change
FROM:

Code: Select all

public static function getMaximumLimit(int $limit) : int {
TO:

Code: Select all

public static function getMaximumLimit($limit) {
I will change it in the same version
Jan
If you find Phoca extensions useful, please support the project

fw115
Phoca Member
Phoca Member
Posts: 32
Joined: 27 Mar 2017, 15:25

Re: Syntax error in pagination.php on line 41 after Update to 3.03

Post by fw115 » 22 Jan 2018, 16:26

Hi Jan,

Code: Select all

php -v 
PHP 5.6.33-0+deb8u1
Thank you.

PHP switch to PHP 7 is scheduled here in Feb 2018

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 43634
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Syntax error in pagination.php on line 41 after Update to 3.03

Post by Jan » 22 Jan 2018, 16:59

Did the change fix the problem?
PHP switch to PHP 7 is scheduled here in Feb 2018
Yes, this was an error, fixed to work with PHP 5.

Jan
If you find Phoca extensions useful, please support the project

fw115
Phoca Member
Phoca Member
Posts: 32
Joined: 27 Mar 2017, 15:25

Re: Syntax error in pagination.php on line 41 after Update to 3.03

Post by fw115 » 22 Jan 2018, 17:19

Hi Jan, sorry forgot to mention that: Yes the fix worked. So Thank you

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 43634
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Syntax error in pagination.php on line 41 after Update to 3.03

Post by Jan » 22 Jan 2018, 18:16

Ok, thank you.
If you find Phoca extensions useful, please support the project

Post Reply