Phoco Template php

Phoca Font - rendering external fonts in Joomla! CMS
Topaz
Phoca Member
Phoca Member
Posts: 21
Joined: 01 Sep 2011, 05:31

Phoco Template php

Post by Topaz » 10 Oct 2016, 10:41

Sorry if this is the wrong board but nearest I could find to subject
The Template component shows
Notice: Use of undefined constant DS - assumed 'DS' in C:\xampp\htdocs\j362\administrator\components\com_phocatemplate\phocatemplate.php on line 12

Warning: require_once(C:\xampp\htdocs\j362\administrator/components/com_phocatemplateDScontroller.php): failed to open stream: No such file or directory in C:\xampp\htdocs\j362\administrator\components\com_phocatemplate\phocatemplate.php on line 12

Fatal error: require_once(): Failed opening required 'C:\xampp\htdocs\j362\administrator/components/com_phocatemplateDScontroller.php' (include_path='C:\xampp\php\PEAR') in C:\xampp\htdocs\j362\administrator\components\com_phocatemplate\phocatemplate.php on line 12
Localhost xampp
Database Version 5.5.5-10.1.16-MariaDB
Database Collation utf8_general_ci
Database Connection Collation utf8mb4_general_ci
PHP Version 7.0.9

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42557
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Phoco Template php

Post by Jan » 11 Oct 2016, 11:27

Hi, which template do you use? Which version? In which Joomla! version?

Jan
If you find Phoca extensions useful, please support the project

Topaz
Phoca Member
Phoca Member
Posts: 21
Joined: 01 Sep 2011, 05:31

Re: Phoco Template php

Post by Topaz » 11 Oct 2016, 11:39

Joomla 3.6.2
Learn sample data
Protostar front end
Isis admin
No modification
Bulk standard fresh install

Will do another install when I have time and see if I can replicate.

Topaz
Phoca Member
Phoca Member
Posts: 21
Joined: 01 Sep 2011, 05:31

Re: Phoco Template php

Post by Topaz » 12 Oct 2016, 01:36

Just tried again and same error

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42557
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Phoco Template php

Post by Jan » 14 Oct 2016, 18:34

Hi, now I see, Phoca Template component is not available for Joomla! 3 now, only for Joomla! 2.5
https://www.phoca.cz/download/category/5 ... -component
If you find Phoca extensions useful, please support the project

Topaz
Phoca Member
Phoca Member
Posts: 21
Joined: 01 Sep 2011, 05:31

Re: Phoco Template php

Post by Topaz » 15 Oct 2016, 10:48

Dooooooh I never looked properly ... I saw the languages for it are J3 but never noticed the component itself wasn't.

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42557
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Phoco Template php

Post by Jan » 19 Oct 2016, 14:40

Hi, yes, mostly the langue which works for 2.5 works for 3.5. But yes, it is confused, I have fixed it (changed to only 2.5). Thank you for the info.

Jan
If you find Phoca extensions useful, please support the project

User avatar
vga
Phoca Newbie
Phoca Newbie
Posts: 1
Joined: 28 Nov 2016, 14:57

Re: Phoco Template php

Post by vga » 28 Nov 2016, 15:39

Hello Jan!
I also have installed Phoca Template Component from here https://www.phoca.cz/download/category/5 ... -component
I am from Ukraine and using Joomla_3.6.2-jino-ru (russian translation) package.
I didn't see what Joomla version this is component, so I have had error messages from Joomla.

Fatal error: Class PhocaTemplatecpController cannot extend from interface JController in C:\xampp\htdocs\Joomla_3.6.2-jino-ru\administrator\components\com_phocatemplate\controller.php on line 49

Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\Joomla_3.6.2-jino-ru\libraries\joomla\session\handler\native.php on line 184

Now I enter to your site and I've noticed my mistake.
Phoca Template Component works properly only in Joomla version 2.5.

I want to ask you.
What about Joomla version 3.5-3.6?
Is this component not modern and not necessary in nowadays?
Why is it outdated a little?
Can this component be useful for creating or customizing new templates ?

Thank you for your answer and your job (another components, modudes, plugins and e.t.c.).

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42557
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Phoco Template php

Post by Jan » 28 Nov 2016, 23:52

Hi, Phoca Template is Joomla! 2.5 component only.

Jan
If you find Phoca extensions useful, please support the project

Post Reply