Warning: Declaration of phocaFontCpController

Phoca Font - rendering external fonts in Joomla! CMS
BrainTrust
Phoca Member
Phoca Member
Posts: 42
Joined: 27 Apr 2016, 18:40

Warning: Declaration of phocaFontCpController

Post by BrainTrust » 27 Apr 2016, 18:55

Hello,

first of all - sorry for my bad english :-(
I tried to install PhocaFonts on my Joomla.
I downloaded this file: com_phocafont_v3.0.1.zip & de-DE.com_phocafont.zip
Open the Backend search for the first File on my Desktop and press the upload and install Button.
I got the green Message that PhocaFonts was installed, but in the same Time I got this message:

Code: Select all

Warning: Declaration of phocaFontCpController::display() should be compatible with JControllerLegacy::display($cachable = false, $urlparams = Array) in C:\xampp\htdocs\Testos\administrator\components\com_phocafont\controller.php on line 42
I was looking for this file and search the Line with the number 42

Code: Select all

class phocaFontCpController extends JControllerLegacy
{
        function display() {
                parent::display();
        }
}
?>
I can handle joomla but I do know nothing about code :-S - sorry

Some informations about my Joomla installation:
local installation with XAMPP
Joomla 3.5.1
PHP version: 7.0.4
Database: mySQLi
You need mor information, please tell me...

Thank You for your time
kind regards
BrainTrust

christine
Phoca Hero
Phoca Hero
Posts: 1938
Joined: 28 Nov 2010, 17:20

Re: Warning: Declaration of phocaFontCpController

Post by christine » 28 Apr 2016, 00:18

Hallo BrainTrust,

Nachdem Du auch: de-DE.com_phocafont.zip installiert hast, nehme ich an, dass Du Deutsch sprichst. :wink:

Generelle Infos: http://www.reisefotografien.eu/phoca-be ... komponente

Hast Du auch das Plugin installiert und aktiviert?

https://www.phoca.cz/download/category/4 ... ont-plugin

Liebe Grüße, Christine

BrainTrust
Phoca Member
Phoca Member
Posts: 42
Joined: 27 Apr 2016, 18:40

Re: Warning: Declaration of phocaFontCpController

Post by BrainTrust » 28 Apr 2016, 18:54

Hallo Christine,

besten Dank für Deine schnelle Antwort. Nein ich habe nur die Componente installiert. Habe jetzt versucht nachzuvolliehen warum mir das PlugIn durch die Lappen ging...
Zuerst war ich auf dieser Seite: https://www.phoca.cz/phocafont
Dann bin ich auf Download gegangen und habe die Componente heruntergeladen. Dort war leider nichts von einem PlugIn zu lesen ^^
Ich werde jetzt mal das PlugIn installieren und dann bescheid geben pb ich es geschafft habe.
Nochmal Danke für Deine Hilfe
Schöne Grüße
BrainTrust

BrainTrust
Phoca Member
Phoca Member
Posts: 42
Joined: 27 Apr 2016, 18:40

Re: Warning: Declaration of phocaFontCpController

Post by BrainTrust » 28 Apr 2016, 19:14

Hallo,
jetzt habe ich zuerst auf eine frische Joomla Installation das PlugIn hochgeladen und aktiviert und dann habe ich die Componente hinterhergeschoben. Wieder der gleiche Fehler. Hier ein Screenshot, damit Du siehst was ich meine:
Image

Code: Select all

Warning: Declaration of phocaFontCpController::display() should be compatible with JControllerLegacy::display($cachable = false, $urlparams = Array) in C:\xampp\htdocs\Testos\administrator\components\com_phocafont\controller.php on line 42
Jetzt installiere ich nochmal Joomla neu und versuche zuerst die Componente und dann das PlugIn zu installieren.

Schöne Grüße
BrainTrust

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42557
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Warning: Declaration of phocaFontCpController

Post by Jan » 28 Apr 2016, 20:57

Hallo, danke für die Information, siehe:

https://www.phoca.cz/documents/50-phoca/ ... tic-method

Ich werde es in nächster Version korrigieren.

Danke, Jan
If you find Phoca extensions useful, please support the project

BrainTrust
Phoca Member
Phoca Member
Posts: 42
Joined: 27 Apr 2016, 18:40

Re: Warning: Declaration of phocaFontCpController

Post by BrainTrust » 29 Apr 2016, 04:59

Hallo Jan,
Besten Dank für Deine rasche Antwort.
Werde es gleich nach Dienstende ausprobieren.

Schöne Grüße
BrainTrust

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42557
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Warning: Declaration of phocaFontCpController

Post by Jan » 29 Apr 2016, 14:43

Ok
If you find Phoca extensions useful, please support the project

BrainTrust
Phoca Member
Phoca Member
Posts: 42
Joined: 27 Apr 2016, 18:40

Re: Warning: Declaration of phocaFontCpController

Post by BrainTrust » 30 Apr 2016, 13:19

Hallo Jan,

bin gerade dabei die php.ini von XAMPP zu ändern...
ich soll nach dieser Zeile suchen:

Code: Select all

error_reporting = E_ALL  | E_STRICT
und diese so anpassen:

Code: Select all

error_reporting = E_ALL | E_DEPRECATED
jetzt schaut die Zeile in meiner php.ini aber so aus:

Code: Select all

error_reporting=E_ALL & ~E_DEPRECATED & ~E_STRICT
ich habe diese Zeile dennoch durch

Code: Select all

error_reporting = E_ALL | E_DEPRECATED
ersetzt und leider funktioniert das nicht...
Hast Du noch eine Idee?

Besten Dank und
schöne Grüße
BrainTrust

Ed:
Ich habe die Alte Zeile nun genommen und so angepasst:

Code: Select all

error_reporting=E_ALL & ~E_DEPRECATED
Einige Zeilen Fehlermeldungen sind verschwunden aber diese blieb:

Code: Select all

 Warning: Declaration of phocaFontCpController::display() should be compatible with JControllerLegacy::display($cachable = false, $urlparams = Array) in C:\xampp\htdocs\Testos\administrator\components\com_phocafont\controller.php on line 42

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42557
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Warning: Declaration of phocaFontCpController

Post by Jan » 02 May 2016, 01:00

Hallo, du kannst es in Global Configuration von Joomla! ändern:

Joomla! administration - System - Global Configuration - Server - Error reporting.

Jan
If you find Phoca extensions useful, please support the project

BrainTrust
Phoca Member
Phoca Member
Posts: 42
Joined: 27 Apr 2016, 18:40

Re: Warning: Declaration of phocaFontCpController

Post by BrainTrust » 02 May 2016, 19:38

Hallo,
tut mir leid, ich bin anscheinend auch einer der Vollidioten die nicht richtig lesen können....
Jetzt hats geklappt ;-)
Besten Dank für den trotzdem sehr netten Support - Danke!

Schöne Grüße
BrainTrust

Post Reply