Image and Links not working in newsletter in jml 3.4.1

Phoca Email (Newsletter) - sending emails and managing newsletters in Joomla! CMS
jeejeestudio
Phoca Enthusiast
Phoca Enthusiast
Posts: 94
Joined: 12 Feb 2008, 13:44
Location: Netherlands

Image and Links not working in newsletter in jml 3.4.1

Post by jeejeestudio » 17 Jun 2015, 17:35

Hi Jan/Benno,

i'm using your latest email and newsletter components.
And as far as i know with Joomla 3.3.6 all worked fine. Images in the newsletter only worked as long as TinyMCE as editor was used.

Now i updated to Joomla 3.4.1, and it seems that the images are not send within the newsletter (whatever editor you use TinyMCE or JCE),
and links are non-clickable links with a very long token.

Also this came in the email/newsletter:
Normal 0 21 false false false EN-US JA X-NONE /* Style Definitions */ table.MsoNormalTable {mso-style-name:Standaardtabel; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin-top:0cm; mso-para-margin-right:0cm; mso-para-margin-bottom:8.0pt; mso-para-margin-left:0cm; line-height:125%; mso-pagination:widow-orphan; font-size:9.0pt; font-family:"Century Gothic","sans-serif"; mso-ascii-font-family:"Century Gothic"; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:"Century Gothic"; mso-hansi-theme-font:minor-latin;}

I also use some commands which now do not seem to work correct:
{articlelink}
{unsubscribelink}
{name}

can you please check if you have same results?

Thanks a lot

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42636
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Image and Links not working in newsletter in jml 3.4.1

Post by Jan » 22 Jun 2015, 00:35

Hi, the commands - what you mean, they are not working correctly?

Images - did you try to add the image with full path to the article (article html code)?

Jan
If you find Phoca extensions useful, please support the project

jeejeestudio
Phoca Enthusiast
Phoca Enthusiast
Posts: 94
Joined: 12 Feb 2008, 13:44
Location: Netherlands

Re: Image and Links not working in newsletter in jml 3.4.1

Post by jeejeestudio » 22 Jun 2015, 19:32

Hi,

The commands which should generate a link are not working anymore.
They do not generate a correct link anymore.
Eiteher a full string with an unclickable token is generated, or an link is generated which you can click on, but nothing happens is generated.

Furtermore the strange string which is in my first post is generated in the email.

Images i normally import via JCE or Tynimce, the way you normally import an image. Worked before.

But as i said as of Joomla 3.4.1 it is not working correct anymore.

Thanks!

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42636
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Image and Links not working in newsletter in jml 3.4.1

Post by Jan » 25 Jun 2015, 22:34

Hi, not sure if I understand correctly:

"Images i normally import via JCE or Tynimce, the way you normally import an image. Worked before."

So which method you are adding the images now?

Jan
If you find Phoca extensions useful, please support the project

jeejeestudio
Phoca Enthusiast
Phoca Enthusiast
Posts: 94
Joined: 12 Feb 2008, 13:44
Location: Netherlands

Re: Image and Links not working in newsletter in jml 3.4.1

Post by jeejeestudio » 25 Jun 2015, 22:49

Hi Jan,

just the same way via jce or tinymce. But the images are not displayed anymore in the received email.

Thanks!

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42636
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Image and Links not working in newsletter in jml 3.4.1

Post by Jan » 25 Jun 2015, 23:28

If you look at the source code of the email (html source code), can you see the image tag there :idea:

Jan
If you find Phoca extensions useful, please support the project

jeejeestudio
Phoca Enthusiast
Phoca Enthusiast
Posts: 94
Joined: 12 Feb 2008, 13:44
Location: Netherlands

Re: Image and Links not working in newsletter in jml 3.4.1

Post by jeejeestudio » 26 Jun 2015, 11:35

Hi Jan,

parts of the email source
<title>TESTmailing</title></head><body style="padding:0;margin:0;"><p>Â <img src="images/blablabla.gif" alt="blablabla" width="184" height="184" />blablabla</p>

<p>http://www.blablabla.nl/component/phoca ... 24cafeb</p>

so the links are there, but no image to see.
Also clickable links are clickable but not responding(not openening the browser)
or they show the whole token string

Thanks!

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42636
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Image and Links not working in newsletter in jml 3.4.1

Post by Jan » 28 Jun 2015, 14:35

Hi, this seems like the image does not have the right path, maybe the editor cuts it. When you change the html source code, when you add fult path to your image, is there the same problem?

Testing now these parameters:
{articlelink}
{unsubscribelink}
{name}

I get no problems :idea:

Jan
If you find Phoca extensions useful, please support the project

jeejeestudio
Phoca Enthusiast
Phoca Enthusiast
Posts: 94
Joined: 12 Feb 2008, 13:44
Location: Netherlands

Re: Image and Links not working in newsletter in jml 3.4.1

Post by jeejeestudio » 30 Jun 2015, 22:19

Hi Jan i got an email from a subscriber that when he clicked the link he got this in his browser.
res://ieframe.dll/syntax.htm#nl/in-memoriam

well i think i will re-install it maybe that helps.
Can i do this without loosing subscribers?

Thanks!

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42636
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Image and Links not working in newsletter in jml 3.4.1

Post by Jan » 04 Jul 2015, 20:22

Hi, when you upgrade the component then the data will be not lost (means you just install new version)

When you reinstall it (means you will uninstall previous version and install new, then the data will be lost, so when such action is done, the backup needs to be done)

Unfortunately I cannot go to link in your post, it is disabled by antivirus :Idea:
If you find Phoca extensions useful, please support the project

Post Reply