Newsletter not sending to all subscribers in group

Phoca Email (Newsletter) - sending emails and managing newsletters in Joomla! CMS
p38
Phoca Member
Phoca Member
Posts: 20
Joined: 02 Aug 2014, 23:39

Newsletter not sending to all subscribers in group

Post by p38 » 11 Feb 2015, 23:06

Hi Jan,

Of a list of 245 subscribers, PhocaEmail only sends to half of these. And I cannot see any pattern in the problem sending of those not sent.

What I do notice is the status list does not show the subscriber details of those not sent.

Unfortunately there is no error messages, so I cannot even begin to check.

All subscribers have valid emails. As you can see, this happens randomly in the list where I have chunks of subscribers that are blank, ie: no green status message.

Do you know what could be the problem. I cant send again, as it would irritate some subscribers.

Image

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42636
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Newsletter not sending to all subscribers in group

Post by Jan » 12 Feb 2015, 23:12

Hi, try to enable firebug e.g. in firefox with opened console - to see if you don't get any javascript / ajax error :idea:

I have checked the code, and the ajax which sends the emails, is asynchronous, so it waits for the answer when sending the email :idea:

Hmmm, try to look into your errorLog file on your server, maybe there will be some error message (e.g. some limit for the sending of emails :idea: )

Jan
If you find Phoca extensions useful, please support the project

p38
Phoca Member
Phoca Member
Posts: 20
Joined: 02 Aug 2014, 23:39

Re: Newsletter not sending to all subscribers in group

Post by p38 » 25 Feb 2015, 22:54

Hi Jan,

The errorlog on the server shows nothing, and my service provider says that all mails requested to send were sent.

So this tells me the error occurs within the Phoca Mailer.

Strange thing is that blocks of emails do not get sent randomly throughout my list, so if there was a problem with mail limits, it would always end at that point and the rest of the mails would then not be sent.

If I look at the mailer list, the last few emails at end of list is sent, the first are sent, and random blocks in between are sent, but not all.

Paul.

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42636
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Newsletter not sending to all subscribers in group

Post by Jan » 28 Feb 2015, 23:45

Hi, the problem is, there is no Phoca Mailer - Phoca Email just uses standard Joomla! mail function from Joomla! to send emails - so in fact it tells Joomla! to send the emails - this is why the settings is in Joomla! Global configuration. My idea was, it can somehow be blocked e.g. because of sending more emails step by step in a short time, but this I cannot test - as on my different test servers, there is no such problem, the same on server of users where we have tested this feauture in the beginning :idea: :-(

So maybe the ajax function needs to be customized - adding some time delay e.g. 3 - 5 seconds before sending to other users.

administrator/components/com_phocaemail\views\phocaemailsendnewsletter\tmpl\default.php - there is stored the ajax, so maybe some delay should be added and tested:

The delay can be added to for:

Code: Select all

function doSetTimeout(i) {
  setTimeout(function() {}, 3000);
}

Code: Select all

for (var i = 0; i < slength; i++) {
  doSetTimeout();
 ...
:idea:
If you find Phoca extensions useful, please support the project

Post Reply