Subscribe button not working correctly

Phoca Email (Newsletter) - sending emails and managing newsletters in Joomla! CMS
User avatar
Hazzo
Phoca Newbie
Phoca Newbie
Posts: 8
Joined: 04 Aug 2021, 16:21

Subscribe button not working correctly

Post by Hazzo » 23 Sep 2021, 10:26

Hi, I installed Phoca Email and Newsletter components and followed the setup directions.
When I try to subscribe from the frontend (hitting the subscribe button) it redirects to /index.php/en/component/phocaemail/subscribe which is not found on the server.

Where can I set up a page cofirming the subscription?

Best regards

Hans

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 44464
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Subscribe button not working correctly

Post by Jan » 23 Sep 2021, 13:29

Hi, is Phoca Email component properly displayed? Which version of Joomla do you use?

Did you set the menu link to Newsletter? When not, try to set it.

Image

Jan
If you find Phoca extensions useful, please support the project

Jupp
Phoca Newbie
Phoca Newbie
Posts: 4
Joined: 21 Oct 2021, 11:56

Re: Subscribe button not working correctly

Post by Jupp » 21 Oct 2021, 12:07

Hello Jan, I have the same problem.
The menu link to the newsletter is set. There is still a -404 error because the page
https://www.domain.tld/newsletter/subscribe.html cannot be found.
The Joomla version is 4.0.3

I'm spinning in circles here ...

Any Idea?

BR
Yup

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 44464
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Subscribe button not working correctly

Post by Jan » 25 Oct 2021, 00:44

Hi, do you get the same problem when SEF is disabled?

Do you get the same problem when SEF is enabled but URL suffix disabled?

Jan
If you find Phoca extensions useful, please support the project

Jupp
Phoca Newbie
Phoca Newbie
Posts: 4
Joined: 21 Oct 2021, 11:56

Re: Subscribe button not working correctly

Post by Jupp » 25 Oct 2021, 10:52

Hello Jan, thank you for your answer.
If the Joomla own SEF (SEO) is deactivated, the links and the registration work.
Is that wanted or is there a workaround to fix it?

BR
Jupp

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 44464
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Subscribe button not working correctly

Post by Jan » 03 Nov 2021, 20:40

Hi, no, normally it should work. When there is a menu link to newsletter, the SEF link is based on this newsletter link. Are you really sure, the link exists and is published?

Jan
If you find Phoca extensions useful, please support the project

Jupp
Phoca Newbie
Phoca Newbie
Posts: 4
Joined: 21 Oct 2021, 11:56

Re: Subscribe button not working correctly

Post by Jupp » 15 Nov 2021, 18:52

Hello Jan, Yes, I am.

If you want, i can give you an access.

BR
Jupp

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 44464
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Subscribe button not working correctly

Post by Jan » 18 Nov 2021, 22:52

Hi, yes.
If you find Phoca extensions useful, please support the project

Jupp
Phoca Newbie
Phoca Newbie
Posts: 4
Joined: 21 Oct 2021, 11:56

Re: Subscribe button not working correctly

Post by Jupp » 21 Nov 2021, 12:23

I'm sorry, but I can't PM you right now.
BR
Jupp

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 44464
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Subscribe button not working correctly

Post by Jan » 28 Nov 2021, 14:29

Hi, you should be able to read the PM? Did you get my last PM?

Jan
If you find Phoca extensions useful, please support the project

Post Reply