Multiple maps not shown - only the first one

Phoca Maps - displaying maps in Joomla! CMS
andreas.albrecht
Phoca Newbie
Phoca Newbie
Posts: 3
Joined: 07 Dec 2018, 19:49

Multiple maps not shown - only the first one

Post by andreas.albrecht » 07 Dec 2018, 19:56

Hi,
I installed phoca map on my joomla 3.9.1 website here:
https://sicherung.transalp.info/infos/karten with id1 - it works.
Then I created 2 other maps with id 2 und 3 and inserted
the code {phocamaps view=map|id=2} here
https://sicherung.transalp.info/mtb/dolomiti-1
only blank screen
and code
{phocamaps view=map|id=3} here
https://sicherung.transalp.info/mtb/bod ... o-maggiore
only blank screen.
What could be wrong?


User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 40534
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Multiple maps not shown - only the first one

Post by Jan » 08 Dec 2018, 12:44

Hi, on your site, there is no javascript problem but I even don't see any loading og google maps API :idea:

Which version of Phoca Maps component and which version of Phoca Maps Plugin do you use?

Jan
If you find Phoca extensions useful, please support the project

andreas.albrecht
Phoca Newbie
Phoca Newbie
Posts: 3
Joined: 07 Dec 2018, 19:49

Re: Multiple maps not shown - only the first one

Post by andreas.albrecht » 08 Dec 2018, 13:49

Hi Jan!
Thanks for quick response. I'm uising com_phocamaps_v3.0.5 and plg_content_phocamaps_v3.0.5
I got a new API key from Google two days before and I inserted this key after installing phoca maps (options).
The strange thing is:
At first I inserted the code {phocamaps view=map|id=1} here:
https://sicherung.transalp.info/infos/karten
and it works. Then I inserted the same code {phocamaps view=map|id=1} here:
https://sicherung.transalp.info/albrecht-route/v2
It doesn't work, only blank screen.

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 40534
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Multiple maps not shown - only the first one

Post by Jan » 08 Dec 2018, 22:04

Hmmm, are both links article view?

Jan
If you find Phoca extensions useful, please support the project

andreas.albrecht
Phoca Newbie
Phoca Newbie
Posts: 3
Joined: 07 Dec 2018, 19:49

Re: Multiple maps not shown - only the first one

Post by andreas.albrecht » 10 Dec 2018, 00:11

In my opinion it is a problem of Rendering the Source code. In my Firefox Browser JavaScript is enabled (I checked this twice). When I insert this link https://sicherung.transalp.info/karten e.g. in Facebook to create a post, the preview tells me, „Javasript Must be enabled in Order to use Google Maps...“
Maybe the reason why is the template of Joomla, which I use (Hera 3..).
Anyway, you did a Great job, Jan, to create this Component.

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 40534
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Multiple maps not shown - only the first one

Post by Jan » 13 Dec 2018, 15:21

Hi, the easy way to test if the problem is in template is to switch to some standard (for test only) :idea:

Jan
If you find Phoca extensions useful, please support the project

Post Reply