Maps not shown when calling page with https

hohlkotase
Phoca Newbie
Phoca Newbie
Posts: 4
Joined: 07 Jun 2009, 16:03

Maps not shown when calling page with https

Post by hohlkotase » 02 Apr 2016, 13:29

Hi

when opening a page with https, the map is not shown. The debug console says that soome calls to http://www.google.com and http://ajax.googleapis.com have been blocked.

Is it possible to overcome this or can we not run the full site / page with https and Phoca Maps?

Thanks for your help.
Edmund


User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 39060
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Maps not shown when calling page with https

Post by Jan » 07 Apr 2016, 18:15

Hi, you can enable https in Options.

Jan
If you find Phoca extensions useful, please support the project

hohlkotase
Phoca Newbie
Phoca Newbie
Posts: 4
Joined: 07 Jun 2009, 16:03

Re: Maps not shown when calling page with https

Post by hohlkotase » 10 Apr 2016, 09:50

Thanks for that. Now it works fine.

Edmund

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 39060
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Maps not shown when calling page with https

Post by Jan » 12 Apr 2016, 12:56

Ok
If you find Phoca extensions useful, please support the project

hieblmedia
Phoca Newbie
Phoca Newbie
Posts: 1
Joined: 21 Jun 2016, 18:13

Re: Maps not shown when calling page with https

Post by hieblmedia » 21 Jun 2016, 18:23

Hello,
some customers wrote me about this after SSL was enabled.

Suggestion:
I think, there should be no extra option for this. I see no advantage here.
This should be handled by the code with including external libraries only with https or protocol-relative.

Sincerly,
Reinhard

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 39060
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Maps not shown when calling page with https

Post by Jan » 22 Jun 2016, 17:06

Hi, the parameter was here because of history where both versions were possible.

When you enable https? Does it not work for you or your customers?

Jan
If you find Phoca extensions useful, please support the project

janpihl
Phoca Member
Phoca Member
Posts: 12
Joined: 16 Apr 2014, 09:20

Re: Maps not shown when calling page with https

Post by janpihl » 05 Jan 2017, 16:21

I have the same problem.

But I have Enable SSL API Load - Yes
and a google API key installed.

But the https i blocking the map.

see: https://www.padleopplevelser.no/index.php/no

Dearest
Jan

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 39060
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Maps not shown when calling page with https

Post by Jan » 05 Jan 2017, 20:18

Hi, which version of Phoca Maps do you use, in your code I don't see any url to Google Maps, in latest version standard https google maps api site is used :idea:

Jan
If you find Phoca extensions useful, please support the project

G0HXT
Phoca Newbie
Phoca Newbie
Posts: 1
Joined: 06 Jan 2017, 11:46

Re: Maps not shown when calling page with https

Post by G0HXT » 06 Jan 2017, 11:52

I have a similar issue, intermittently my map does not show. Sometimes it loads other times it won't and on other occasions I get the map but the zoom buttons are white. I'm using https and the option is turned on. Running version 3.04.

Andy

PJrN
Phoca Member
Phoca Member
Posts: 19
Joined: 17 Jun 2016, 20:38

Re: Maps not shown when calling page with https

Post by PJrN » 08 Jan 2017, 18:26

Hello, I have the same problem.
Map doesn't load.
Any idea?

I have lot of pages with map.
https://www.votatuprofesor.com/centros- ... u-ikastola

https://www.votatuprofesor.com/centros- ... -ermua-bhi

1- Enabled https on options
2- Last update version of the plugin and component v3.0.4

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest