Open Graph System Plugin doesn't output any tags for Featured Articles menu items

Phoca plugins - support for all Phoca plugins except Phoca Gallery plugins
User avatar
Abatap
Phoca Member
Phoca Member
Posts: 13
Joined: 15 Jan 2019, 18:37

Open Graph System Plugin doesn't output any tags for Featured Articles menu items

Post by Abatap » 15 Jan 2019, 19:08

Hello and thank you for these free plugins. Please see the topic subject for my question. Is there a reason for such behavior? It pretty much breaks Open Graph for my main page. It doesn't seem to be tied to a particular template as the behavior is the same to both of the stock Joomla! templates.

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 40833
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Open Graph System Plugin doesn't output any tags for Featured Articles menu items

Post by Jan » 19 Jan 2019, 19:24

Hi, which plugin do you use? System or Content?

Jan
If you find Phoca extensions useful, please support the project

User avatar
Abatap
Phoca Member
Phoca Member
Posts: 13
Joined: 15 Jan 2019, 18:37

Re: Open Graph System Plugin doesn't output any tags for Featured Articles menu items

Post by Abatap » 19 Jan 2019, 19:32

I'm using both of them since I need Open Graph tags both in Article Menu Items and non com_content menu items like VirtueMart pages and other 3rd party extension views where the system plugin works perfectly BUT not in "Featured Articles" view menu items for some reason. Right not I'm in a situation where I have og metadata pretty much everywhere except for my main page which is set to Featured Articles which is also Joomla!'s default state for menu.

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 40833
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Open Graph System Plugin doesn't output any tags for Featured Articles menu items

Post by Jan » 19 Jan 2019, 19:55

Hi, hmm, the content should display it on featured articles website - like in blog

Do you have enabled the content plugin to be displayed in featured view?

Image

Jan
If you find Phoca extensions useful, please support the project

User avatar
Abatap
Phoca Member
Phoca Member
Posts: 13
Joined: 15 Jan 2019, 18:37

Re: Open Graph System Plugin doesn't output any tags for Featured Articles menu items

Post by Abatap » 19 Jan 2019, 20:09

Yep, I have it enabled since it's the default setting. Maybe the problem lies in the fact that I don't actually have any featured articles displayed on my main page so the plugin has nothing to output? But in that case, shouldn't it just fallback to global values like Joomla! site title and description along with Image link set on the "Article Options" tab, because that's how it works in "Category Blog" views when there are no any articles to display? Pretty much the only way I can get any og tags on my main page now is through adding an "Articles - Newsflash" module somewhere to the page but of course it's far from ideal because it starts outputting their title as og:title and their featured image as og:image which is not what I would like to see on my main page.

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 40833
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Open Graph System Plugin doesn't output any tags for Featured Articles menu items

Post by Jan » 27 Jan 2019, 19:50

Hi, unfortunately, Joomla! system plugin itself cannot somehow switch from featured to blog, etc. - It just gets the info in which view it is run and then it can somewho behave but it cannot somehow switch to another view :-(
If you find Phoca extensions useful, please support the project

User avatar
Abatap
Phoca Member
Phoca Member
Posts: 13
Joined: 15 Jan 2019, 18:37

Re: Open Graph System Plugin doesn't output any tags for Featured Articles menu items

Post by Abatap » 27 Jan 2019, 20:25

Hello, I'm a bit confused by your reply because it seems to me that there is either some misunderstanding or these technical details are simply beyond my understanding, so I'll try to clarify some things.

As far as I understand now is that not the System plugin responsible for outputting Open Graph tags for Featured Articles view pages but the Content one is (the one without the "System" word in its name in other words) so my initial question was kind of incorrect.

My problem is that my page set to "Featured articles" which is also what the default Joomla! installation comes with so it's totally not like we're having some exotic, hard to recreate situation going on. But I get absolutely zero Open Graph tags output on my main page as if the plugin isn't there. I should also point out that I don't actually have any featured articles on my site so the main page contains only modules. At the same time the plugin works well with any other Article page (menu item set to "Single Article" I should say) and even with completely empty "Category blog" menu items where it outputs fallback title and description BUT for some reason it outputs whole nothing for empty "Featured articles" pages and works as expected as long as at least one featured article is displayed. So my question now is: Is this a bug or is there some technical limitation of the Joomla! platform which prevents the plugin from working as expected?

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 40833
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Open Graph System Plugin doesn't output any tags for Featured Articles menu items

Post by Jan » 29 Jan 2019, 00:59

Hi, I cannot say what is exactly the view - where your featured articles are displayed. But in case it is just standard com_content featured view and there is no article, the content plugin cannot display anything - it just does not get any information about article, so there is no data to display something. So the plugin does not have any information of which view should be displayed, etc. It just recognize, it is running inside the feautured view but if the featured view has no data, it doesn't get any data to display something... not sure if I understand you correctly.

Jan
If you find Phoca extensions useful, please support the project

User avatar
Abatap
Phoca Member
Phoca Member
Posts: 13
Joined: 15 Jan 2019, 18:37

Re: Open Graph System Plugin doesn't output any tags for Featured Articles menu items

Post by Abatap » 29 Jan 2019, 02:26

if the featured view has no data, it doesn't get any data to display something... not sure if I understand you correctly.
Yes, but it still outputs Open Graph tags with fallback values for empty "Category Blog" views. Why it cannot be the same for empty "Featured Articles" views?

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 40833
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Open Graph System Plugin doesn't output any tags for Featured Articles menu items

Post by Jan » 29 Jan 2019, 16:50

Hmmm, can you paste here some example of the meta tags which you get when you have empty category blog?

Jan
If you find Phoca extensions useful, please support the project

Post Reply