Page 1 of 1

Very serious problem with og tags! Pls help!!

Posted: 12 Oct 2018, 09:11
by cvrak
Hi,

I'm using Phoca Content plugin and suddenly og tags are messed.
Some og tags are correct from Joomla article, and some of them are wrong from a specific K2 item!
The URL of a page is https://www.chrisomelo.com/el/proionta/ ... ortokalias

The source code is
<base href="https://www.chrisomelo.com/el/proionta/ ... ortokalias" />
<meta name="og:title" content="Το Χρυσόμελο στην Ιαπωνία" />
<meta name="og:type" content="article" />
<meta name="og:image" content="https://www.chrisomelo.com/images/News_ ... pan_02.jpg" />
<meta name="og:url" content="https://www.chrisomelo.com/el/proionta/ ... ortokalias" />
<meta name="og:site_name" content="Chrisomelo" />
<meta name="og:description" content="Το Χρυσόμελο στην Ιαπωνία" />
<meta name="author" content="Chris" />
<meta name="description" content="Chrisomelo" />

og:title, og:image, og:description are wrong, they are from a K2 item.

The same problem occurs for every page.
I un-installed & re-installed the plugin, but the problem remains.

What happened? How this serious issue can be corrected?
Pls advice

Thanks in advance
Chris

Re: Very serious problem with og tags! Pls help!!

Posted: 12 Oct 2018, 18:29
by Jan
Hi, which extension do you use? Phoca Opengraph Conten Plugin or Phoca Opengraph System Plugin? Does the K2 don't use some specific solution for this?

Jan

Re: Very serious problem with og tags! Pls help!!

Posted: 12 Oct 2018, 18:32
by cvrak
I'm using Phoca Opengraph Content plugin.
The strange thing is that 2 days ago everything was ok

Re: Very serious problem with og tags! Pls help!!

Posted: 12 Oct 2018, 20:44
by Jan
Hmmm, do you use any other system plugin, which can somehow change the output of your html?

Jan

Re: Very serious problem with og tags! Pls help!!

Posted: 13 Oct 2018, 08:08
by cvrak
Jan wrote:
12 Oct 2018, 20:44
Hmmm, do you use any other system plugin, which can somehow change the output of your html?

Jan
I'm not sure how I can check it.

I'm using Jf Simone Gantry template for the site. If I change to Gantry Hydrogen default template, the problem is gone.
Any advice?

Thanks

Re: Very serious problem with og tags! Pls help!!

Posted: 13 Oct 2018, 10:10
by cvrak
Finally I've found what's wrong!
A module position from template causes the problem.
Explain: on the right top of the page there are 3 lines which unfold a K2 kategory. Obviously this module is placed above everything and confuses the plugin.
You can see what I mean at the home page www.chrisomelo.com
Pls can you suggest a solution? My customer wants this feature.

Thanks in advance
Chris

Re: Very serious problem with og tags! Pls help!!

Posted: 15 Oct 2018, 17:57
by Jan
Hmmm, hard to give some clue advice, I don't know K2, etc. Normally the plugin should get info only from the article (content). The parameters, etc. should be taken from article not module. I think, there must be done some debug on your site directly inside the plugin code so you will know, what exactly is influencing the output :idea: :idea:

Jan