Joomla! 2.5 to 3.x upgrade with Phoca Extensions

Phoca Documentation - creating documentation in Joomla! CMS
phidias81
Phoca Enthusiast
Phoca Enthusiast
Posts: 70
Joined: 05 Jan 2012, 01:20
Contact:

Re: Joomla! 2.5 to 3.x upgrade with Phoca Extensions

Post by phidias81 » 19 Oct 2014, 06:06

Edit to the previous post: After I had to rebuild my joomla for some problems, the method above didn't work anymore. When trying to install Phocagallery, I was getting error 404 component not found, so I had to use this alternative method
viewtopic.php?f=1&t=26433&p=101497#p101497

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42539
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Joomla! 2.5 to 3.x upgrade with Phoca Extensions

Post by Jan » 23 Oct 2014, 17:37

Ok
If you find Phoca extensions useful, please support the project

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42539
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Joomla! 2.5 to 3.x upgrade with Phoca Extensions

Post by Jan » 02 Dec 2014, 19:00

If you find Phoca extensions useful, please support the project

Easytherm
Phoca Newbie
Phoca Newbie
Posts: 9
Joined: 05 May 2011, 10:51
Location: Switzerland
Contact:

Re: Joomla! 2.5 to 3.x upgrade with Phoca Extensions

Post by Easytherm » 08 Dec 2014, 23:54

thank you so much for your so awaited upgrade tutorial.

I'll try it for my sites and keep you informed, then send you a couple of € as thank your

regards

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42539
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Joomla! 2.5 to 3.x upgrade with Phoca Extensions

Post by Jan » 12 Dec 2014, 14:37

Ok, thank you, Jan
If you find Phoca extensions useful, please support the project

MarioP
Phoca Member
Phoca Member
Posts: 20
Joined: 22 Oct 2013, 15:25
Location: Poland

Re: Joomla! 2.5 to 3.x upgrade with Phoca Extensions

Post by MarioP » 20 Feb 2015, 14:33

Hi,
Could someone help me...I successfully migrated from J! 2.5.8 to J!3.3.6 and now trying to install the Phoca Dowload component I have the following error :
An error has occurred. 404 Component not found
Should the old version of Phoca be uninstalled or just disabled? I disabled it.
Of course I'm following the tutorial by Jan https://www.phoca.cz/documents/50-phoca/ ... o-joomla-3
What can be wrong? What about phoca plugins? Should the old vesrions of the plugins be uninstalled before the update to the ones compatible with J3!?

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42539
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Joomla! 2.5 to 3.x upgrade with Phoca Extensions

Post by Jan » 22 Feb 2015, 01:34

Hi, the plugins do not include any data, so you can uninstall and install them again (the data in fact are stored in articles - still writing about plugins)

If you get the 404, this seems like this problem:

https://www.phoca.cz/documents/16-joomla ... -menu-link

but before removing it from system, be sure you have exported (backuped) the data from Phoca Download database, so they can be imported when new install is done.

Jan
If you find Phoca extensions useful, please support the project

MarioP
Phoca Member
Phoca Member
Posts: 20
Joined: 22 Oct 2013, 15:25
Location: Poland

Re: Joomla! 2.5 to 3.x upgrade with Phoca Extensions

Post by MarioP » 24 Feb 2015, 15:26

Hi,
This is what I did
- after I had updated the Joomla to 3.3.6 I deleted the old Phoca Download component and the plugins from Joomla ( by the default Joomla Extension Manager->Uninstall command)
- installed the Phoca Download for J!3 and the plugins. Then imported the priorly backuped data by FTP and phpMyAdmin (TRUNCATE TABLE command and import_ the phocadownload.sql file)
At first sight everything seems to be fine (especially that the update from J!2.5 to J!3 seems to resolve my problem with Phoca Download Plugin viewtopic.php?f=33&t=28227 - but I will confirm that when be 100% sure).
I'd like to report that I had an issue with "Up Icon" - back to categories view. After I had clicked on it I had the following notification:
404 error: View not found [name, type, prefix]: phocadownload, html, phocadownloadView
It turned out that I have to reassign phoca component to Joomla menu - I had the "Component 'com_phocadownload' does not exist" notification in the menu item leading to Phoca Component.

One issue remains for me:
In J!2.5 categories (categories view) were placed in nicely looking, grey rectangles - in J!3 I'm not able to gain that effect...

And one more question - is the method I had followed correct? I mean is that correct that at first step I uninstalled the Phoca for J!2.5 and then installed the one for J3 (after I updated to J!3)? Or should I try to install the new version of Phoca while the old one is still present in the extensions? It is not clearly stated in the tutorial or I'm not able to find it https://www.phoca.cz/documents/50-phoca/ ... o-joomla-3 Maybe that's why I had the issue with the menu items...
About the time issue mentioned in that article https://www.phoca.cz/documents/16-joomla ... -menu-link - I've installed a lot more sizeable extentions than Phoca and I had no problems like that. Besides I'm not a programmer so I prefered to try to use this method. I don't know whether rightly....

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42539
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Joomla! 2.5 to 3.x upgrade with Phoca Extensions

Post by Jan » 27 Feb 2015, 13:58

Hi, try to see for the rectangles:

viewtopic.php?f=31&t=28513&p=104810#p104896

Jan
If you find Phoca extensions useful, please support the project

rickjs
Phoca Newbie
Phoca Newbie
Posts: 2
Joined: 19 Apr 2014, 01:13

Re: Joomla! 2.5 to 3.x upgrade with Phoca Extensions

Post by rickjs » 07 Jul 2015, 02:35

Hi,

For the instructions in "How to migrate extensions from Joomla! 2.5 to Joomla! 3", does this mean after backup of db and folders, I uninstall the Phoca extension before Joomla upgrade?

Rick

Post Reply