user upload image to frontend gallery, the image is not displayed.

Phoca Gallery - image gallery extension
Patrick1957
Phoca Member
Phoca Member
Posts: 12
Joined: 10 Mar 2019, 11:57

user upload image to frontend gallery, the image is not displayed.

Post by Patrick1957 » 22 Feb 2021, 13:14

Version Phoca Gallery
4.4.1

Hi !
user image upload to frontend gallery, the image is not displayed.
The image is well in the server.
The file name is: Paysage Version1.jpg

Before the last update, all uppercases and spaces worked.
Now that doesn't work anymore.

Where and how do I change the code to make it work again?

Regards
Patrick

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 43759
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: user upload image to frontend gallery, the image is not displayed.

Post by Jan » 22 Feb 2021, 14:48

Hi,

what you mean with:
"Before the last update, all uppercases and spaces worked."

When you upload image without spaces, do you get the same problems?

Where exactly is the image not displayed?

(Spaces were never supported as it can have different issues on different servers, see: https://www.phoca.cz/documents/2-phoca- ... ing-images )

You can see the changes here:
https://github.com/PhocaCz/PhocaGallery ... ebf55de568

Jan
If you find Phoca extensions useful, please support the project

Patrick1957
Phoca Member
Phoca Member
Posts: 12
Joined: 10 Mar 2019, 11:57

Re: user upload image to frontend gallery, the image is not displayed.

Post by Patrick1957 » 22 Feb 2021, 14:59

Thanks , Jan

without spaces, no problem.
image is not displayed in user gallery and in Phoca ACL

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 43759
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: user upload image to frontend gallery, the image is not displayed.

Post by Jan » 22 Feb 2021, 15:05

Hmmm, I am testing it now on windows, and I can even upload and add image with spaces (but it is not recommended). There were no changes regarding spaces so really hard to say.

What exactly is not displayed, the image itself or the image item?

Image

When no whole item, didn't you get any error message when uploading? Did you test both methods - single upload and multiple upload?

Jan
If you find Phoca extensions useful, please support the project

Patrick1957
Phoca Member
Phoca Member
Posts: 12
Joined: 10 Mar 2019, 11:57

Re: user upload image to frontend gallery, the image is not displayed.

Post by Patrick1957 » 22 Feb 2021, 15:35

It's very weird, now it seems to be working normally .... Yet I haven't changed anything.

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 43759
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: user upload image to frontend gallery, the image is not displayed.

Post by Jan » 22 Feb 2021, 15:44

Hmm, really hard to say what could be wrong there :idea:

Jan
If you find Phoca extensions useful, please support the project

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 43759
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: user upload image to frontend gallery, the image is not displayed.

Post by Jan » 25 Feb 2021, 01:09

BTW (thank you for the info from Christine) if you are using spaces, it can really work differently on different systems, can work on Windows but can be problematic on Linux, so it is really not recommended to use them.

Jan
If you find Phoca extensions useful, please support the project

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 43759
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: user upload image to frontend gallery, the image is not displayed.

Post by Jan » 25 Feb 2021, 01:46

But try to test this version:
https://github.com/PhocaCz/PhocaGallery ... .2Beta.zip
where I have reverted the changes, so maybe it will work for you. Just install this version (do not uninstall the previous version) and let me know.

Jan
If you find Phoca extensions useful, please support the project

Patrick1957
Phoca Member
Phoca Member
Posts: 12
Joined: 10 Mar 2019, 11:57

Re: user upload image to frontend gallery, the image is not displayed.

Post by Patrick1957 » 25 Feb 2021, 02:55

Thanks, but
I edited this code :
administrator\components\com_phocagallery\libraries\phocagallery\file\fileupload.php
line 93, 263, 358, 499
I added everywhere " strtolower "

$filepathImgFinal = JPath::clean($path->image_abs.$folder.strtolower($file['name']));
$filepathImgTemp = JPath::clean($path->image_abs.$folder.$tempFolder.strtolower($file['name']));

Now it works fine. For example, this file : ' Essais éct Fin.jpg ' is loaded

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 43759
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: user upload image to frontend gallery, the image is not displayed.

Post by Jan » 25 Feb 2021, 13:36

So, yes, these are the changes which were reverted, so I will release the 4.4.2 and it should work.

Thank you for the info.

Jan
If you find Phoca extensions useful, please support the project

Post Reply