Unable to display comments

Phoca Gallery - image gallery extension
bradverts
Phoca Newbie
Phoca Newbie
Posts: 3
Joined: 26 May 2020, 14:14

Unable to display comments

Post by bradverts » 26 May 2020, 14:21

Latest phoca and Joomla
Comments were working on images, then I did something that stopped them working. I can add a comment and it appears in the back end, but I can't find the way of displaying it on the page now. Im sure this must be simple, but I have fiddled for hours! Can anyone point me in the right direction please? There is an add comment icon but not a read comment icon

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42650
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Unable to display comments

Post by Jan » 27 May 2020, 21:25

Hi, the easiest ways is of course to find what was changed or to recreate your site from backup (if it exists).

Can you paste a screenshots of view where do you display the comments? Does your site use template overrides?

Jan
If you find Phoca extensions useful, please support the project

bradverts
Phoca Newbie
Phoca Newbie
Posts: 3
Joined: 26 May 2020, 14:14

Re: Unable to display comments

Post by bradverts » 28 May 2020, 13:59

Hi Jan, I have installed Comments which seems to work but isn't as good as the built in one, I don't think. I had the images opening up on the page and the comments were underneath. The template can use overrides. I'd like to get back to the built in comment system if I can for simplicity.

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42650
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Unable to display comments

Post by Jan » 28 May 2020, 14:34

Hi, which "Comments" did you install? Did you set even the parameters for displaying the comments?

Jan
If you find Phoca extensions useful, please support the project

bradverts
Phoca Newbie
Phoca Newbie
Posts: 3
Joined: 26 May 2020, 14:14

Re: Unable to display comments

Post by bradverts » 28 May 2020, 18:54

Hi Jan, sorry the autocorrect hit! Should have said - "I have installed Jcomments"
When using the Phoca gallery initially worked, then I broke something somewhere and although I could add comments, they were visible in the back end but not the front end.

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 42650
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Unable to display comments

Post by Jan » 31 May 2020, 20:36

Hmmm, hard to give some clue advice, mostly the best way is to apply the backup or reinstall the component (which is easy to say but hard to do :-( ). No another clue advice :-(

Jan
If you find Phoca extensions useful, please support the project

Post Reply