Images not showing in Slimbox (detail view)

Before you ask see the Phoca Gallery User Manual
karaoke
Phoca Member
Phoca Member
Posts: 11
Joined: 07 Feb 2010, 11:47

Images not showing in Slimbox (detail view)

Post by karaoke » 17 Aug 2018, 17:27

Hi there,

I have around 120 categories in Phocagallery each category include 30-40 images. For some unknown reasons images of some galleries are not showing up in detail view when the detail window is set to Slimbox. I don't see this problem if I set the detail window to Modal Box, Shadowbox, Highslide JS, etc.
Other categories are working smoothly with Slimbox.

Can somebody tell me why this is happenning?


User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 40431
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Images not showing in Slimbox (detail view)

Post by Jan » 18 Aug 2018, 10:12

Hi, this can be caused by some javascript error/conflict :idea: Try to see the javascript console on the site where the error occurs, maybe you will find some more info :idea:
https://www.phoca.cz/documents/16-jooml ... -conflicts

Jan
If you find Phoca extensions useful, please support the project

karaoke
Phoca Member
Phoca Member
Posts: 11
Joined: 07 Feb 2010, 11:47

Re: Images not showing in Slimbox (detail view)

Post by karaoke » 18 Aug 2018, 10:36

Hi Jan,

Thank you for your response.
There is no Javascript error or conflict. I've checked developer tools console. The odd thing is that this problem only exists in some categories while images in other categories are showing up in slimbox without any problem.

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 40431
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Images not showing in Slimbox (detail view)

Post by Jan » 18 Aug 2018, 13:55

Hi, can I see it where this occurs?

Jan
If you find Phoca extensions useful, please support the project

karaoke
Phoca Member
Phoca Member
Posts: 11
Joined: 07 Feb 2010, 11:47

Re: Images not showing in Slimbox (detail view)

Post by karaoke » 18 Aug 2018, 17:59

Hi Jan,

Please go to http://sigvardsen.net/index.php/myndir

The images in the categories in the upper half of this page are working OK. The problem persists for the lower half categories of the page.

christine
Phoca Hero
Phoca Hero
Posts: 1403
Joined: 28 Nov 2010, 17:20

Re: Images not showing in Slimbox (detail view)

Post by christine » 18 Aug 2018, 19:20

Hi,

I think the reason are wrong image names. For example:

http://sigvardsen.net/index.php/myndir/ ... ember_2005 >
<a class="slimbox" title="" href="/images/phocagallery/thumbs/phoca_thumb_l_klap_(medium)_1.jpg" rel="lightbox-november_2005"><img src="/images/phocagallery/thumbs/phoca_thumb_m_klap_(medium)_1.jpg" alt="klap (Medium).jpg" class="pg-image img img-responsive c-Image c-Image--shaded" itemprop="thumbnail"></a>

see here: https://www.phoca.cz/documents/2-phoca- ... ing-images
There can be problems with image names (folder names) on some servers. Before you upload your images into a server, please check the image names (folder names). They shouldn't contain spaces or some bad characters (', ", #, ...), diacritics or special national characters.
Kind regards
Christine

Post Reply