PG 4.3.9 Categories ALT not working

Before you ask see the Phoca Gallery User Manual
Captain Hook
Phoca Newbie
Phoca Newbie
Posts: 7
Joined: 12 Jan 2018, 21:57

PG 4.3.9 Categories ALT not working

Post by Captain Hook » 12 Jan 2018, 22:33

Hey,

currently I am using Phoca Gallery 4.3.9 with Joomla 3.8.3 and PHP7.

I'd like to adjust in categories view the parameters under Catergories ALT adjustments. For each value of style there is no reaction in the frontend.
The other effect I see is by using the shaddowbox the category view look different than under https://www.phoca.cz/demo/shadowbox meaning there is still a White Frame around the Picture instead of Frame directly at the Picture.
Another issue is by trying to deactivate the Frames around the thumbs in category view via CSS file Fails. I tried several methods found in the Internet.
http://vga3.vereinsgemeinschaft-aichhalden.de/index.php
Can you help me?

Thanks


christine
Phoca Hero
Phoca Hero
Posts: 1306
Joined: 28 Nov 2010, 17:20

Re: PG 4.3.9 Categories ALT not working

Post by christine » 12 Jan 2018, 23:13

Hallo,

weiß nicht genau, ob ich Dich richtig verstanden habe. Willst Du jetzt Schatten ohne Rahmen oder keinen Schatten :wink:

kein Schatten - kein Rahmen (in Deine Haupt CSS vom Template):

Code: Select all

.pg-cv-box {
box-shadow:none;
border: none !important;	
}
Liebe Grüße
Christine

Captain Hook
Phoca Newbie
Phoca Newbie
Posts: 7
Joined: 12 Jan 2018, 21:57

Re: PG 4.3.9 Categories ALT not working

Post by Captain Hook » 13 Jan 2018, 00:00

Hallo,
Vorzugsweise hätte ich gerne keine Schatten und keine Rahmen um die Thumbs. Falls das nicht geht dann die Rahmen/Schatten direkt um das Thumb Bild drum herum ohne Abstand.
Den angegebenen Code Teil aus Deiner Antwort habe ich in der Customer.css drin, leider ohne Auswirkung.
Grüße

christine
Phoca Hero
Phoca Hero
Posts: 1306
Joined: 28 Nov 2010, 17:20

Re: PG 4.3.9 Categories ALT not working

Post by christine » 13 Jan 2018, 00:13

Hallo,
Bei mir funktioniert es temporär. Ich sehe auch keine "Customer.css" bzw. custom.css.
Es gibt eine: http://vga3.vereinsgemeinschaft-aichhal ... plate9.css >/template9.css und da sehe ich den Code nicht.

Liebe Grüße
Christine

Captain Hook
Phoca Newbie
Phoca Newbie
Posts: 7
Joined: 12 Jan 2018, 21:57

Re: PG 4.3.9 Categories ALT not working

Post by Captain Hook » 13 Jan 2018, 00:26

Hallo,
Die Customer.css liegt unter Templates/lessallrounder/css.
Grüße

christine
Phoca Hero
Phoca Hero
Posts: 1306
Joined: 28 Nov 2010, 17:20

Re: PG 4.3.9 Categories ALT not working

Post by christine » 13 Jan 2018, 00:36

Wie das im Allrounder Template compiliert wird, kann ich nicht wissen. Im Quelltext sehe ich keine.
Sehe die obgenannte.
Strengstensfalls gibst es halt in die default.css von der Phocagallery. Musst dann aber wahrscheinlich ein !important; dranhängen.

Warum ich immer bei Änderungen drauf hinweise, dies in die eigene template.css oder custom.css oder, oder zu geben (Templates sind ja unterschiedlich) ist der Grund, weil bei einem PG Update sonst die Änderung weg ist.

Liebe Grüße
Christine

christine
Phoca Hero
Phoca Hero
Posts: 1306
Joined: 28 Nov 2010, 17:20

Re: PG 4.3.9 Categories ALT not working

Post by christine » 13 Jan 2018, 00:45

Zum Template Lessallrounder:

hab dort im Forum geschaut. Hier z.B. wird es u.a. erklärt: (da geht es zwar um etwas anderes, aber Funktionsweise der custom.css): http://bakual.net/forum/support/521-hea ... alten.html
Dann erstellst du eine /templates/lessallrounder/css/custom.css Datei und schreibst da die angepassten CSS Regeln rein. Nach jeder Änderung in dieser Datei musst du den Templatestil neu speichern damit er die Änderung übernimmt.
Liebe Grüße
Christine

Captain Hook
Phoca Newbie
Phoca Newbie
Posts: 7
Joined: 12 Jan 2018, 21:57

Re: PG 4.3.9 Categories ALT not working

Post by Captain Hook » 13 Jan 2018, 00:51

Hallo Christine,
Habe den Code Teil mal in die default.css eingefügt. Das hat funktioniert. Cool.
Allerdings wie von dir angesprochen hat es den großen Nachteil, dass die default.css beim nächsten PG update überschrieben wird. Deswegen wäre es möglich die Schattenbox zum laufen zu bekommen?
Grüße

christine
Phoca Hero
Phoca Hero
Posts: 1306
Joined: 28 Nov 2010, 17:20

Re: PG 4.3.9 Categories ALT not working

Post by christine » 13 Jan 2018, 00:57

Hallo,

deswegen schickte ich Dir ja obigen Auszug vom Lessallrounder Template. Denn wenn Du bei der Seite grundsätzlich was ändern möchtest, musst Du es ja sowieso (siehe oben) so machen.

Was Du jetzt mit: "Schattenbox zum Laufen" meinst, weiß ich jetzt nicht.

Liebe Grüße
Christine

Captain Hook
Phoca Newbie
Phoca Newbie
Posts: 7
Joined: 12 Jan 2018, 21:57

Re: PG 4.3.9 Categories ALT not working

Post by Captain Hook » 13 Jan 2018, 01:04

Hallo,
sorry, habe das mit der template9.css erst nicht gepeilt d.h. dass dieses File Teil des Templates ist und nicht der PhocaGallery. Habe das in meiner lokalen Kopien ausprobiert und es funktioniert wunderbar. Super, Dankeschön.
Soweit würde es funktionieren.
Grüße

Post Reply