Deprecated: implode()

Phoca Gallery - image gallery extension
reggaebkk
Phoca Newbie
Phoca Newbie
Posts: 3
Joined: 24 Oct 2021, 11:04

Deprecated: implode()

Post by reggaebkk » 24 Oct 2021, 11:13

Hi,
1st thin, thanks for the extension, it is great!

I am having a problem because in the pages where I inserted galleries in content, I get this error message:
Deprecated: implode(): Passing glue string after array is deprecated. Swap the parameters in /home/public_html/plugins/content/phocagallery/phocagallery.php on line 1604

I updated the component and plugin to latest version for Joomla 3.9, my Joomla is also up to date, but it doesn't resolve the issue, I still get that error message like in this page:
https://lomorng.org/index.php/about-us/about-lom-orng

Any idea of what I should do next?

christine
Phoca Hero
Phoca Hero
Posts: 2272
Joined: 28 Nov 2010, 17:20

Re: Deprecated: implode()

Post by christine » 24 Oct 2021, 12:12

Hi,

Are you using current Joomla version: 3.10.2 (on oct,26th: 3.10.3)
PG Component: 4.4.3, Plugin: 4.4.2
Which PHP version?

Kind regards
Christine

reggaebkk
Phoca Newbie
Phoca Newbie
Posts: 3
Joined: 24 Oct 2021, 11:04

Re: Deprecated: implode()

Post by reggaebkk » 24 Oct 2021, 13:56

Thanks for the fast reply.
PHP version is 7.4
Joomla version is 3.10.2
Component 4.4.3 (now that I've updated, but I still have the error message)
Plugin 4.4.2

christine
Phoca Hero
Phoca Hero
Posts: 2272
Joined: 28 Nov 2010, 17:20

Re: Deprecated: implode()

Post by christine » 24 Oct 2021, 15:31

Hi,

under developer console I see some loading of Javascript are blocked.

In addition maybe to find the reason for Deprecated: implode():

Would be useful to enable debug mode and error reporting in Joomla! Configuration.
Error reporting to Maxium. Debug Settings: Yes. To get more information where this problem occurs. So called "Call Stack"
And to write these informations here.

Kind regards
Christine

reggaebkk
Phoca Newbie
Phoca Newbie
Posts: 3
Joined: 24 Oct 2021, 11:04

Re: Deprecated: implode()

Post by reggaebkk » 24 Oct 2021, 15:43

Actually your reply made me notice that for some reasons my config was to error reporting maximum, I don't know why it changed. I set it back to simple and the error message is gone, so since everything works it's fine for me like this, thanks a lot.

christine
Phoca Hero
Phoca Hero
Posts: 2272
Joined: 28 Nov 2010, 17:20

Re: Deprecated: implode()

Post by christine » 24 Oct 2021, 16:34

Hi,

as it was/is a "warning only" and not "fatal" error message, you can set configuration error reporting to: simple.

For developer might be useful to know about this message & all system versions (we got above) to check. Will inform Jan about.

Kind regards
Christine

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 44464
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Deprecated: implode()

Post by Jan » 24 Oct 2021, 22:29

Hi, try to update the plugin to version 4.4.3, it should be OK now:

https://www.phoca.cz/download/category/ ... ery-plugin

Jan
If you find Phoca extensions useful, please support the project

Post Reply