Upgrade TinyMCE Editor Plugin in Joomla! 1.5

Category: Joomla!
This guide describes how to upgrade TinyMCE editor in Joomla! 1.5.
Obsolete version of TinyMCE editor plugin used in Joomla! 1.5 does not work correctly with Internet Explorer 9. This affects Phoca Guestbook. If you get the following error after posting a message in Phoca Guestbook: "Please enter content", and you are sure, you have written some content while posting a message, then seems like TinyMCE installed in your Joomla! 1.5 does not work correctly with Internet Explorer 9. To fix it, do the following steps:

1 Download and install TinyMCE 3 editor plugin (3.4.6) in your Joomla! 1.5 site - TinyMCE editor plugin download site (use standard Joomla! 1.5 extension installation).


2 Go to Phoca Guestbook parameters: Joomla! Administration - Components - Phoca Guestbook - click on Parameters: Find Enable Javascript Editor parameter and set: Yes (TinyMCE3).

Setting TinyMCE 3 in Phoca Guestbook
Now Phoca Guestbook will use TinyMCE 3 editor plugin to work correctly in Internet Explorer 9.
If you want to enable TinyMCE 3 editor plugin for your whole Joomla! site (for articles e.g.), go to: Joomla! Administration - Site - Global Configuration and set Default WYSIWYG Editor parameter to: Editor - TinyMCE 3.
Setting TinyMCE 3 in Global Configuration