Phoca Options problem

Cast-Art
Phoca Member
Phoca Member
Posts: 25
Joined: 07 Apr 2009, 10:46
Location: Nederland
Contact:

Phoca Options problem

Postby Cast-Art » 23 Feb 2012, 11:10

Hello,

In Phoca 3.1.4 as well as in Phoca 3.1.5 an http 500 error is displayed or an empty page when I use the Options button.
The Joomla version is 2.5.1. The error occurs in IE, FFend GC and on different computers
A couple of days ago it still worked.

Regards
Carel


millsstew526
Phoca Newbie
Phoca Newbie
Posts: 1
Joined: 24 Feb 2012, 03:32
Contact:

Re: Phoca Options problem

Postby millsstew526 » 24 Feb 2012, 03:37

I am having the exact same issue here, please help! It's getting confusing :x

Cast-Art
Phoca Member
Phoca Member
Posts: 25
Joined: 07 Apr 2009, 10:46
Location: Nederland
Contact:

Re: Phoca Options problem

Postby Cast-Art » 24 Feb 2012, 13:57

The options link looks like:

http://www.vishandeldejager.nl/administ ... =component

The parameter path = empty
Could that be the cause?
If so how could this happen?

Cast-Art
Phoca Member
Phoca Member
Posts: 25
Joined: 07 Apr 2009, 10:46
Location: Nederland
Contact:

Re: Phoca Options problem

Postby Cast-Art » 24 Feb 2012, 14:10

I tried the next link:

http://www.vishandeldejager.nl/administ ... ocagallery

and it worked.

It seems that if you leave out the path and the tmpl parameters it works.

Now the question is, which file do I have to change?

Cast-Art
Phoca Member
Phoca Member
Posts: 25
Joined: 07 Apr 2009, 10:46
Location: Nederland
Contact:

Re: Phoca Options problem

Postby Cast-Art » 24 Feb 2012, 16:46

Correction
If you leave out path=


So http// your domain /administrator/ index.php?option=com_config&view=component&component=com_phocagallery&tmpl=component

might work

Cast-Art
Phoca Member
Phoca Member
Posts: 25
Joined: 07 Apr 2009, 10:46
Location: Nederland
Contact:

Re: Phoca Options problem

Postby Cast-Art » 29 Feb 2012, 10:31

I did some more trial and error and found out that:

.....administrator/index.php?option=com_config&view=component&component=com_contact&path=&tmpl=component
(option link in component Contacts)

works and

.....administrator/index.php?option=com_config&view=component&component=com_phocagallery&path=&tmpl=component
(option link in component Phoca Gallery)

not any more.

Is there anybody who can help me finding a solution

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 37375
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Phoca Options problem

Postby Jan » 01 Mar 2012, 23:52

Hi, 500 is mostly php error, enable php error reporting to get info about the error:

http://www.phoca.cz/documents/16-joomla ... rs-on-site

Jan
If you find Phoca extensions useful, please support the project

Cast-Art
Phoca Member
Phoca Member
Posts: 25
Joined: 07 Apr 2009, 10:46
Location: Nederland
Contact:

Re: Phoca Options problem

Postby Cast-Art » 02 Mar 2012, 10:50

I installed Joomla 2.5.1 and Phoca Gallery 3.1.5 once again in a new root.

Options works fine now but there another problem occurred!
If I load an new image in a category, only the medium thumbnail is created and the image doesn't appear in the images list. It happens in both cases Jfile thumbnail creation on and off

If you upload all images in a folder first and the assign the images 1 by 1 to a category, the small , medium en large thumbnails are generated!

If you want to assign an image to a category and the image is not in the folder yet
then after uploading only the medium thumbnail is generated and no record is written in the databse in which the assignment is stored

For now the problem is solved I can continue.
I'm going to check the PHP settings later

Cast-Art
Phoca Member
Phoca Member
Posts: 25
Joined: 07 Apr 2009, 10:46
Location: Nederland
Contact:

Re: Phoca Options problem

Postby Cast-Art » 10 Mar 2012, 19:30

In Joomla administrator the System Cache parameter must be "off"
Then the problem with thumbnail creation is solved.

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 37375
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Phoca Options problem

Postby Jan » 12 Mar 2012, 23:02

Ok
If you find Phoca extensions useful, please support the project


Return to “General Forum”

Who is online

Users browsing this forum: No registered users and 1 guest