Open Graph - loads partially wrong content

Question about all Phoca plugins except Phoca Gallery plugins which have own forum
HerKle
Phoca Newbie
Phoca Newbie
Posts: 4
Joined: 31 Jan 2016, 15:47

Open Graph - loads partially wrong content

Post by HerKle » 19 Apr 2017, 13:45

Hi,
after enabling SEF URL rewrite, JCH Optimize and JotCache on our website, I observe strange behaviour of Phoca Open Graph. When tryin g to share an article on Facebook, I got wright picture but wrong title and wrong description.

Of course, I cleaned all caches. I even deactivated the plugin, but yet, after re-activating it still delivers wrong og:title and og:description although everything else is correct. All settings of the plugin are left to default.

Here ist the source code of the meta tags

Code: Select all

<meta name=keywords content=cannabispolitik />
<meta name=og:title content="Renovierung des Gruppentreffs"/>
og:title should be: "Wieder und wieder und wieder"

Code: Select all

<meta name=og:type content=article />
<meta name=og:image content=http://guttempler.de/images/bundesverband/artikel/2017/cannada_620.png />
<meta name=og:url content=http://guttempler.de/home/aktuelles/684-wieder-und-wieder-und-wieder />
<meta name=og:site_name content="Guttempler in Deutschland"/>
<meta name=og:description content="Die Renovierung unserer Gruppenräume in der Nürnberger Südstadt hat begonnen."/>
og:description should be the same as meta:description

Code: Select all

<meta name=description content="Wir sehen mit Sorge einerseits die Dämonisierung des Cannabis-Konsums und dessen KonsumentInnen, andererseits die Glorifizierung und Verharmlosung des deutschen »Kulturguts« Alkohol."/>
<meta name=generator content="Joomla! - Open Source Content Management"/>
So it seems as if some cache hinders Phoca OG to refresh *all* information. Does anyone has an idea how to fix that?
Thanks for help!
Regards, Herbert


HerKle
Phoca Newbie
Phoca Newbie
Posts: 4
Joined: 31 Jan 2016, 15:47

Re: Open Graph - loads partially wrong content

Post by HerKle » 19 Apr 2017, 22:19

After deinstalling an re-installing the plugin (btw latest version 3.0.8) I receive first correct meta tags – but in a second run again those of another latest article in a different joomla category:

Code: Select all

<meta property=og:title content="Wieder und wieder und wieder …"/>
<meta property=og:type content=article />
<meta property=og:image content=http://guttempler.de/images/bundesverband/artikel/2017/cannada_620.png />
<meta property=og:url content=http://guttempler.de/home/aktuelles/684-wieder-und-wieder-und-wieder />
<meta property=og:site_name content="Guttempler in Deutschland"/>
<meta property=og:description content="Wir sehen mit Sorge einerseits die Dämonisierung des Cannabis-Konsums und dessen KonsumentInnen, andererseits die Glorifizierung und Verharmlosung des deutschen »Kulturguts« Alkohol."/>
<meta property=og:title content="Renovierung des Gruppentreffs"/>
<meta property=og:description content="Die Renovierung unserer Gruppenräume in der Nürnberger Südstadt hat begonnen."/>
So og:title and og-description are listed two times. How comes?

Thanks for help.

Regards, Herbert

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 38022
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Open Graph - loads partially wrong content

Post by Jan » 20 Apr 2017, 16:08

Hi, do you use content plugin or system plugin or both?
If you find Phoca extensions useful, please support the project

HerKle
Phoca Newbie
Phoca Newbie
Posts: 4
Joined: 31 Jan 2016, 15:47

Re: Open Graph - loads partially wrong content

Post by HerKle » 20 Apr 2017, 16:24

Hi Jan,
I have both installed and enabled.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest