Phoca Gallery 4.0.0 Beta - Tags not displaying

scisteffan
Phoca Newbie
Phoca Newbie
Posts: 5
Joined: 12 Mar 2013, 18:16

Phoca Gallery 4.0.0 Beta - Tags not displaying

Postby scisteffan » 09 Apr 2013, 17:31

Hello,

If I add tags to an image in Phoca Gallery 4.0.0 Beta, then click "Save", the tags disappear from the tags textbox. They are in the database, but do not display in the text box.

Also, the function, PhocaGalleryTag::storeTags, should return `true` if tags are stored successfully.


scisteffan
Phoca Newbie
Phoca Newbie
Posts: 5
Joined: 12 Mar 2013, 18:16

Re: Phoca Gallery 4.0.0 Beta - Tags not displaying

Postby scisteffan » 11 Apr 2013, 16:42

The tags do not display due to the use of loadResultArray for the custom fieldtype, PhocaGalleryTag:

Code: Select all

if ($select == 0) {
   $tags = $db->loadResultArray();
} else {
   $tags = $db->loadObjectList();
}


It's been removed in Joomla 3.

scisteffan
Phoca Newbie
Phoca Newbie
Posts: 5
Joined: 12 Mar 2013, 18:16

Re: Phoca Gallery 4.0.0 Beta - Tags not displaying

Postby scisteffan » 11 Apr 2013, 16:48

Just found this that may be really useful for you: http://docs.joomla.org/Potential_backwa ... tform_12.1

JDatabase::loadResultArray() has been removed. Use JDatabase::loadColumn() instead.

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 36872
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Phoca Gallery 4.0.0 Beta - Tags not displaying

Postby Jan » 15 Apr 2013, 23:28

Hi, thank you for the info, I will fix it for the next version.

Jan
If you find Phoca extensions useful, please support the project

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 36872
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: Phoca Gallery 4.0.0 Beta - Tags not displaying

Postby Jan » 09 May 2013, 17:58

Hi, fixed in Phoca Gallery 4.0.0 RC
If you find Phoca extensions useful, please support the project


Return to “Phoca Gallery Development”

Who is online

Users browsing this forum: No registered users and 1 guest