404 - Category is not published

Before you ask see the Phoca Gallery User Manual
djgps
Phoca Newbie
Phoca Newbie
Posts: 2
Joined: 20 Oct 2011, 02:58

404 - Category is not published

Postby djgps » 20 Oct 2011, 03:10

Hi... I have Phoca Gallery and i have a problem like many other people.

I can see the thumbnails but when i clik on thumb no image is displayed and ia get the errow 404 - Category is not published . I Read many solutions and tried almost all but i can not fix the problem.

Finally has someone found the solution and how?

thanks
http://imageshack.us/photo/my-images/189/404errorl.jpg/


User avatar
Benno
Phoca Hero
Phoca Hero
Posts: 5708
Joined: 04 Dec 2008, 11:58
Location: Germany
Contact:

Re: 404 - Category is not published

Postby Benno » 20 Oct 2011, 14:23


djgps
Phoca Newbie
Phoca Newbie
Posts: 2
Joined: 20 Oct 2011, 02:58

Re: 404 - Category is not published

Postby djgps » 23 Oct 2011, 02:06

Hi benno! After many tests i found that when i choose in the PARAMETERS ----- Detail View Settings -----> jak Lightbox it works fine but when i choose some other options it does not work.

Why does this happen? I think it is not a SEF problem...

User avatar
Benno
Phoca Hero
Phoca Hero
Posts: 5708
Joined: 04 Dec 2008, 11:58
Location: Germany
Contact:

Re: 404 - Category is not published

Postby Benno » 24 Oct 2011, 00:11

Hi,
but did you create a menu link to Phoca Gallery Component?

Kind regards,
Benno

gerol80
Phoca Member
Phoca Member
Posts: 15
Joined: 13 Jan 2012, 11:01

Re: 404 - Category is not published

Postby gerol80 » 14 Feb 2012, 14:09

Hi all, hi Benno (yes, it's me again ),

today I again had exactly the same problem with my Phoca Gallery installation. I could open any category and see the thumbnails without any problems. But when I clicked one of the thumbnails, the modal popup window displayed, but it contained an 404 error "Kategorie ist nicht veröffentlicht" ("Category is not published"). I tried several categories and I assume that the issue was present for all categories of my installation.

I then started googleing and e.g. found the hint that a menu entry must be present for the Phoca Gallery component. I have such a menu entry, so this can't be the problem. After some time of trying around I noticed that all the popups magically worked again, without any apparent configuration changes.

Edit: Unfortunately they did not all work again. Now I found another category where the error occurred. After about 2 minutes the popups worked correctly – and I was not even logged in to the Joomla! backend. So the configuration surely did not change.

Edit 2: What came to my mind now: After the 404 error but before the popups worked correctly, I got some popups which actually contained the thumbnails view of another Phoca Gallery category. This was really strange!

As someone in another thread also wrote, it seems to me that Phoca Gallery (or Joomla! or whatever system) needs some time before the links work correctly. I'm not sure what may cause these problems. I recently updated my Apache installation (what required a restart of the Apache server). Perhaps this has to do with the problems. All in all this really is an ugly behavior.

Any ideas what may cause this issue?

Thanks,
Oliver

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 36872
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: 404 - Category is not published

Postby Jan » 16 Feb 2012, 00:46

Hi,
it seems to me that Phoca Gallery (or Joomla! or whatever system) needs some time before the links work correctly


:-) :-)

mostly this is typical cache issue ... you chang someting and it is not working (because everything is working still from cache - not accepted changes) ... and after someone will clean the cache (browser, server, etc.) it then will work :-)

Jan
If you find Phoca extensions useful, please support the project

gerol80
Phoca Member
Phoca Member
Posts: 15
Joined: 13 Jan 2012, 11:01

Re: 404 - Category is not published

Postby gerol80 » 16 Feb 2012, 15:22

Hi Jan,

I don't quite understand what you're trying to tell me :)
Some minutes ago I again accessed my Phoca Gallery and now it doesn't work again. And I'm 100% sure that I did not change anything in the configuration.

What now came to my mind – I did the following:
1. Go to the home page of my website.
2. Go to the gallery using the "random image" module on the home page (in the right side bar).
3. Click a thumbnail --> 404 error.
4. Click another thumbnail --> 404 error.
5. Go to another category and click a thumbnail --> 404 error.

But then:
6. Manually go to the gallery using the menu link "Fotogalerie".
7. Go to some category and click a thumbnail --> works.
8. Go to another category using the "random image" (in the right side bar) and click a thumbnail --> now also works.

Then:
9. Go back to the home page via menu link "Home".
10. Go to the gallery using the "random image" module on the home page (in the right side bar).
11. Click a thumbnail --> again the 404 error.

It seems to me that the issue always happens when I navigate to the gallery using the "random image" module. When I use the menu link everything works correctly. Then, when I'm already inside the gallery, it also works using the "random image" module. This behavior is very strange.

Feel free to try it yourself: http://ffu.nerdocracy.org

What I see:
When I use the menu link, the URLs for the popup look like
http://ffu.nerdocracy.org/index.php/fotogalerie/56-17062007-sommerfest-2007/detail/1119-003?tmpl=component

When I use the "random image" module (only from outside the gallery!), the URLs look like
http://ffu.nerdocracy.org/index.php/component/phocagallery/56-17062007-sommerfest-2007/detail/1119-003?tmpl=component

So it seems to be an SEF issue – but I have a menu link to the gallery!

User avatar
Jan
Phoca Hero
Phoca Hero
Posts: 36872
Joined: 10 Nov 2007, 18:23
Location: Czech Republic
Contact:

Re: 404 - Category is not published

Postby Jan » 18 Feb 2012, 23:05

If you find Phoca extensions useful, please support the project

gerol80
Phoca Member
Phoca Member
Posts: 15
Joined: 13 Jan 2012, 11:01

Re: 404 - Category is not published

Postby gerol80 » 19 Feb 2012, 00:53

Hi Jan,
thanks for your answer. But to be honest, I don't get it :)

I mean, I have a menu link to Phoca Gallery. And if I use this link everything works fine. I only doesn't work if I use the random image module to access the gallery.

Must the menu link point to a specific target? At the moment my link is of type "Phoca Gallery Layout".

User avatar
Benno
Phoca Hero
Phoca Hero
Posts: 5708
Joined: 04 Dec 2008, 11:58
Location: Germany
Contact:

Re: 404 - Category is not published

Postby Benno » 19 Feb 2012, 11:35

Hi,
Must the menu link point to a specific target? At the moment my link is of type "Phoca Gallery Layout".

it should be: "Phoca Galerie Layout Kategorienliste" to get valid item IDs for all categories.

Kind regards,
Benno


Return to “Phoca Gallery”

Who is online

Users browsing this forum: Bing [Bot] and 2 guests